To do this lab, you need to do Lab-1 http://pursuingmydestiny.blogspot.com/2011/12/lab-1-mpls-backbone.html and Lab-2 first http://pursuingmydestiny.blogspot.com/2011/12/lab-2-mpls-vpn.html.
Assume we have customer with name BRI. So BRI1 and BRI2 is CE router. Then we would like to connect our customer using our MPLS Backbone. Connection between BR1 to PE using static route.
Let’s do the lab.
PE1#
ip route vrf BRI_1 10.0.0.1 255.255.255.255 192.168.0.2
!
router bgp 65000
address-family ipv4 vrf BRI_1
redistribute connected
redistribute static
PE2#
ip route vrf BRI_2 10.0.0.2 255.255.255.255 192.168.0.6
!
router bgp 65000
address-family ipv4 vrf BRI_2
redistribute connected
redistribute static
BRI1#
interface Loopback0
ip address 10.0.0.1 255.255.255.255
!
interface FastEthernet0/0
description ###Link to MPLS###
ip address 192.168.0.2 255.255.255.252
!
ip route 0.0.0.0 0.0.0.0 192.168.0.1
BRI2#
interface Loopback0
ip address 10.0.0.2 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.0.6 255.255.255.252
ip route 0.0.0.0 0.0.0.0 192.168.0.5
Let’s verify that MP-BGP vpn vrf BRI_1 already connect to vpn vrf BRI_2
PE1#sh ip bgp vpnv4 vrf BRI_1
BGP table version is 21, local router ID is 10.10.10.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 65000:1 (default for vrf BRI_1)
*> 1.1.1.1/32 0.0.0.0 0 32768 ?
*> 10.0.0.1/32 192.168.0.2 0 32768 ?
*>i10.0.0.2/32 10.10.10.2 0 100 0 ?
*>i22.22.22.22/32 10.10.10.2 0 100 0 ?
*> 192.168.0.0/30 0.0.0.0 0 32768 ?
*>i192.168.0.4/30 10.10.10.2 0 100 0 ?
Let’s check routing table in PE and CE
PE1#show ip route vrf BRI_1
Routing Table: BRI_1
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback1
22.0.0.0/32 is subnetted, 1 subnets
B 22.22.22.22 [200/0] via 10.10.10.2, 00:04:21
10.0.0.0/32 is subnetted, 2 subnets
B 10.0.0.2 [200/0] via 10.10.10.2, 00:04:21
S 10.0.0.1 [1/0] via 192.168.0.2
192.168.0.0/30 is subnetted, 2 subnets
C 192.168.0.0 is directly connected, FastEthernet0/1
B 192.168.0.4 [200/0] via 10.10.10.2, 00:04:21
BRI1#sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.0.1 to network 0.0.0.0
10.0.0.0/32 is subnetted, 1 subnets
C 10.0.0.1 is directly connected, Loopback0
192.168.0.0/30 is subnetted, 1 subnets
C 192.168.0.0 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 192.168.0.1
Let’s test ping from PE1 to BRI2
PE1#ping vrf BRI_1 10.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 88/120/160 ms
Let’s test ping from BRI1 and BRI2 and do trace route
BRI1#ping 10.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/130/184 ms
BRI1#traceroute 10.0.0.2
Type escape sequence to abort.
Tracing the route to 10.0.0.2
1 192.168.0.1 44 msec 44 msec 28 msec
2 192.168.10.2 [MPLS: Labels 16/19 Exp 0] 116 msec 132 msec 96 msec
3 192.168.0.5 [MPLS: Label 19 Exp 0] 120 msec 76 msec 116 msec
4 192.168.0.6 156 msec * 132 msec
Great now we already make MPLS VPN using PE CE static routing.
No comments:
Post a Comment