My Countingdown

Friday, December 16, 2011

Lab 1. MPLS Backbone

MPLS now use almost in all ISP and operator. Why need MPLS? Besides it’s more fastest, it also can accommodate legacy network such ATM, Frame-Relay, etc. By MPLS, we can use for different service such as data traffic internal, customer, frame-relay legacy, ATM legacy etc. By using MPLS, we can use the same IP if the service is differtiated and not leak in VRF.

In MPLS, there are 3 type of router:
  1. PE or Provider Edge
  2. P or Provider
  3. CE or Customer Edge
Here step-by-step building MPLS network:
  1. Create IP point-to-point. Make sure can ping ip p2p
  2. Activate IGP for internal communication in all P and PE. We can use static or dynamic. Normally using dynamic routing such OSPF.
  3. Activate BGP in PE only. We need to activate BGP as we will use MP- BGP for passing routing, vpn, and vrf information.
  4. Activate MPLS between P and PE. When activate MPLS, please make sure that ‘ip cef’ already activated in router.
Actually we need MTU 1512 byte in MPLS for MPLS labeling i.e.: CMIIW
  1. 4 byte for mpls labeling
  2. 4 byte for vpn labeling
  3. and 4 bytes for traffic engineering
We can use to check MPLS information by using
#show mpls forwarding-table


Let’s activate MPLS Backbone PE1-P-PE2

PE1#
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
!
interface FastEthernet0/0
 description ###Link to P Router###
 ip address 192.168.10.1 255.255.255.252   ---- > Create ip p2p
 mpls ip                    ---- >  Activate MPLS interface only in MPLS Backbone
!
router ospf 1            ---- >  Activate IGP for internal MPLS Backbone
 network 10.10.10.1 0.0.0.0 area 0
 network 192.168.10.1 0.0.0.0 area 0
!
router bgp 65000
  neighbor 10.10.10.2 remote-as 65000      ---- >  Activate BGP between PE
  neighbor 10.10.10.2 update-source Loopback0

P#
interface Loopback0
 ip address 10.10.10.10 255.255.255.255
!
interface FastEthernet0/0
 description ###Link to PE1 Router###
 ip address 192.168.10.2 255.255.255.252
 mpls ip
!
interface FastEthernet0/1
 description ###Link to PE2 Router###
 ip address 192.168.20.1 255.255.255.252
 mpls ip
!
router ospf 1
 network 10.10.10.10 0.0.0.0 area 0
 network 192.168.10.2 0.0.0.0 area 0
 network 192.168.20.1 0.0.0.0 area 0

PE2#
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!
interface FastEthernet0/0
 description ###Link to P Router###
 ip address 192.168.20.2 255.255.255.252
 mpls ip
!
router ospf 1
 network 10.10.10.2 0.0.0.0 area 0
 network 192.168.20.2 0.0.0.0 area 0
!
router bgp 65000
 neighbor 10.10.10.1 remote-as 65000
 neighbor 10.10.10.1 update-source Loopback0

Verify MPLS

PE1#show mpls int
Interface              IP            Tunnel   Operational
FastEthernet0/0        Yes (ldp)     No       Yes

PE1#show mpls interfaces detail
Interface FastEthernet0/0:
        IP labeling enabled (ldp):
          Interface config
        LSP Tunnel labeling not enabled
        BGP tagging not enabled
        Tagging operational
        Fast Switching Vectors:
          IP to MPLS Fast Switching Vector
          MPLS Turbo Vector
        MTU = 1500

PE1#show mpls ldp neighbor
    Peer LDP Ident: 10.10.10.10:0; Local LDP Ident 10.10.10.1:0
        TCP connection: 10.10.10.10.23513 - 10.10.10.1.646
        State: Oper; Msgs sent/rcvd: 35/36; Downstream
        Up time: 00:24:13
        LDP discovery sources:
          FastEthernet0/0, Src IP addr: 192.168.10.2
        Addresses bound to peer LDP Ident:
          192.168.10.2    10.10.10.10     192.168.20.1

PE1#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     10.10.10.10/32    0          Fa0/0      192.168.10.2
17     Pop tag     192.168.20.0/30   0          Fa0/0      192.168.10.2
18     17          10.10.10.2/32     0          Fa0/0      192.168.10.2
19     Aggregate   1.1.1.1/32[V]     0
20     Untagged    10.0.0.1/32[V]    0          Fa0/1      192.168.0.2
21     Aggregate   192.168.0.0/30[V] 0
22     Aggregate   11.11.11.11/32[V] 0
23     Aggregate   192.168.0.0/30[V] 0

P#show mpls forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     10.10.10.1/32     3426       Fa0/0      192.168.10.1
17     Pop tag     10.10.10.2/32     4703       Fa0/1      192.168.20.2

1 comment:

  1. Hi,

    First off thank you for some brilliant lab resources and good luck with your mission to get to CCIE. Just thought I'd highlight a possible typo in the configuration for this lab e.g:

    router ospf 1 ---- > Activate IGP for internal MPLS Backbone
    network 10.10.10.1 0.0.0.0 area 0
    network 192.168.10.1 0.0.0.0 area 0

    Thinking that last line should be:

    network 192.168.10.0 0.0.0.3 area 0

    I had no OSPF neighbors etc. forming or MPLS LDP neighborships and that change fixed it. Guessing this is down to OSPF being classful so needing the full subnet mask? Similarly for p2p networks between the other P/PE routers...

    To be honest I was quite grateful for this as it made me really think about what I was doing so probably learned even more! :)

    ReplyDelete