My Countingdown

Wednesday, January 4, 2012

Lab 7. Switching - Router on a Stick and the Native VLAN

Objective: Configure R1 to route traffic between VLAN 13 and VLAN 23. VLAN 13 should be the 802.1q Native VLAN


R1:
R1(config)#int e0/0
R1(config-if)#ip add 13.13.13.1 255.255.255.0
R1(config-if)#no shu
R1(config-if)#ip route 23.23.23.0 255.255.255.0 13.13.13.3

R2:
R2(config)#int e0/2
R2(config-if)#ip add 23.23.23.2 255.255.255.0
R2(config-if)#no shu
R2(config-if)#ip route 13.13.13.0 255.255.255.0 23.23.23.3

R3: 
R3(config)#int e0/3
R3(config-if)#no shu
R3(config-if)#int e0/3.13
R3(config-subif)#encap dot1q 13 native
R3(config-subif)#ip add 13.13.13.3 255.255.255.0
R3(config-subif)#int e0/3.23
R3(config-subif)#encap dot1q 23      
R3(config-subif)#ip add 23.23.23.3 255.255.255.0

SW1:
SW1(config)#vlan 13,23
SW1(config-vlan)#exi

SW1(config)#int e0/0                               ---> to R1
SW1(config-if)#switch acce vla 13
SW1(config-if)#no shu

SW1(config-if)#int e0/1                           ---> to SW2
SW1(config-if)#switch trunk encap dot
SW1(config-if)#switch mod trun
SW1(config-if)#no shu

SW2:
SW2(config)#vla 13,23
SW2(config-vlan)#exi

SW2(config)#int e0/2                             ---> to R2
SW2(config-if)#switch acc vla 23
SW2(config-if)#no shu

SW2(config-if)#int e0/3                          ---> to R3
SW2(config-if)#switch trunk encap dot
SW2(config-if)#switch trunk native vla 13
SW2(config-if)#switch mode trunk
SW2(config-if)#no shu

SW2(config-if)#int e0/1                         ---> to SW1
SW2(config-if)#switc
SW2(config-if)#switc trunk encap dot1
SW2(config-if)#switc mode trunk
SW2(config-if)#no shu

Verify the switchport and trunk

SW1(config-if)#do sh int trunk 
Port                Mode         Encapsulation  Status        Native vlan
Et0/1               on              802.1q            trunking      1

Port                Vlans allowed on trunk
Et0/1               1-4094

Port                Vlans allowed and active in management domain
Et0/1               1,13,23

Port                Vlans in spanning tree forwarding state and not pruned
Et0/1               1,13,23

SW1(config-if)#do sh int e0/1 switch
Name: Et0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Operational Dot1q Ethertype:  0x8100
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Operational Native VLAN tagging: disabled
  
SW2(config-if)#do sh int trunk
Port                Mode         Encapsulation  Status        Native vlan
Et0/1               on              802.1q            trunking      1
Et0/3               on              802.1q            trunking      13

Port                Vlans allowed on trunk
Et0/1               1-4094
Et0/3               1-4094

Port                Vlans allowed and active in management domain
Et0/1               1,13,23
Et0/3               1,13,23

Port                Vlans in spanning tree forwarding state and not pruned
Et0/1               1,13,23
Et0/3               1,13,23

SW2(config-if)#do sh int e0/3 switch
Name: Et0/3
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Operational Dot1q Ethertype:  0x8100
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 13 (VLAN0013)
Administrative Native VLAN tagging: enabled
Operational Native VLAN tagging: disabled

SW2(config-if)#do sh int e0/2 switch
Name: Et0/2
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Operational Dot1q Ethertype:  0x8100
Negotiation of Trunking: On
Access Mode VLAN: 23 (VLAN0023)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Operational Native VLAN tagging: disabled 

SW2(config-if)#do sh int e0/1 switch
Name: Et0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Operational Dot1q Ethertype:  0x8100
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Operational Native VLAN tagging: disabled

Make sure ping is ok

R2#sh ip rou 13.13.13.1
Routing entry for 13.13.13.0/24
  Known via "static", distance 1, metric 0
  Routing Descriptor Blocks:
  * 23.23.23.3
      Route metric is 0, traffic share count is 1


R2#ping 13.13.13.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13.13.13.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/8 ms

Lab 6. Switching - Router on a Stick

Objective: Configure R52 to route traffic between VLAN 13 and VLAN 23 using 802.1q encapsulation


R1:
R1(config)#int e0/0
R1(config-if)#ip add 13.13.13.1 255.255.255.0
R1(config-if)#no shu
R1(config)#ip route 23.23.23.0 255.255.255.0 13.13.13.3

R2:
R2(config)#int e0/1
R2(config-if)#ip add 23.23.23.2 255.255.255.0
R2(config-if)#no shu
R2(config-if)#ip route 13.13.13.0 255.255.255.0 23.23.23.3

R3:
R3(config)#int e0/2
R3(config-if)#no shu

R3(config-if)#int e0/2.13
R3(config-subif)#encapsulation dot1q 13
R3(config-subif)#ip add 13.13.13.3 255.255.255.0

R3(config-subif)#int e0/2.23
R3(config-subif)#encap dot 23
R3(config-subif)#ip add 23.23.23.3 255.255.255.0

SW1:
SW1(config)#vlan 13
SW1(config-vlan)#exi

SW1(config)#vlan 23
SW1(config-vlan)#exi

SW1(config)#int e0/0
SW1(config-if)#switch access vlan 13
SW1(config-if)#no shu

SW1(config-if)#int e0/1
SW1(config-if)#switch acc vla 23
SW1(config-if)#no shu

SW1(config-if)#int e0/2
SW1(config-if)#switc trun encap dot
SW1(config-if)#swit mode trun
SW1(config-if)#no shu

Verify interface

R1#sh ip int bri | i Int|up           
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/0                13.13.13.1      YES manual up                    up

R2(config-if)#do sh ip int bri | i Int|up
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/1                23.23.23.2      YES manual up                    up

R3(config)#do sh ip int bri | i Int|up
Interface                  IP-Address      OK? Method Status                Protocol
Ethernet0/2                   unassigned      YES unset   up                    up     
Ethernet0/2.13             13.13.13.3      YES manual up                    up     
Ethernet0/2.23             23.23.23.3      YES manual up                    up

SW1(config-if)#do sh ip int bri | i Int|up
Interface              IP-Address      OK? Method Status                Protocol
Ethernet0/0            unassigned      YES unset  up                    up     
Ethernet0/1            unassigned      YES unset  up                    up     
Ethernet0/2            unassigned      YES unset  up                    up

Verify the switchport and trunk in SW1

SW1(config-if)#do sh int e0/2 switch
Name: Et0/2
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Operational Dot1q Ethertype:  0x8100
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Operational Native VLAN tagging: disabled

SW1(config-if)#do sh int trun
Port                Mode         Encapsulation  Status        Native vlan
Et0/2               on              802.1q            trunking      1

Port                Vlans allowed on trunk
Et0/2               1-4094

Port                Vlans allowed and active in management domain
Et0/2               1,13,23

Port                Vlans in spanning tree forwarding state and not pruned
Et0/2               1,13,23

Make sure ping is ok

R1#ping 23.23.23.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Tuesday, January 3, 2012

Lab 5. Switching - Trunk Ports without DTP

Objective: Configure an ISL trunk between SW1 and SW2 without DTP (Dynamic Trunking Protocol)


SW1:
SW1(config)#int e0/0
SW1(config-if)#switchport trunk encapsulation isl
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport nonegotiate

SW2:
SW2(config)#int e0/0 
SW2(config-if)#switc trun encap isl
SW2(config-if)#swit mode trun
SW2(config-if)#switc nonegoti

Verify the switchport and trunk

SW1(config-if)#do sh int trun
Port                Mode         Encapsulation  Status        Native vlan
Et0/0               on              isl            trunking      1

Port                Vlans allowed on trunk
Et0/0               1-4094

Port                Vlans allowed and active in management domain
Et0/0               1

Port                Vlans in spanning tree forwarding state and not pruned
Et0/0               1

Name: Et0/0SW1(config-if)#do sh int e0/0 switch
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Operational Dot1q Ethertype:  0x8100
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Operational Native VLAN tagging: disabled
...

SW2(config-if)#do sh int trunk
Port                Mode         Encapsulation  Status        Native vlan
Et0/0               on              isl                    trunking      1

Port                Vlans allowed on trunk
Et0/0               1-4094

Port                Vlans allowed and active in management domain
Et0/0               1

Port                Vlans in spanning tree forwarding state and not pruned
Et0/0               1

SW2(config-if)#do sh int e0/0 switc
Name: Et0/0
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Operational Dot1q Ethertype:  0x8100
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Operational Native VLAN tagging: disabled

Lab 4. Switching - 802.1q Trunk Ports and the Native VLAN

Objective: Configure an 802.1q trunk between SW1 and SW2 with VLAN 20 as the native VLAN 


SW1:
SW1(config)#int e0/0
SW1(config-if)#switch trun encap dot1
SW1(config-if)#switch trun native vlan 20
SW1(config-if)#switchport mode trunk
SW1(config-if)#no shu

SW2:
SW2(config)#int e0/0
SW2(config-if)#switch trun encap dot
SW2(config-if)#switch trunk nati vla 20
SW2(config-if)#switch mode trunk
SW2(config-if)#no shu

Verify the switchport and trunk 

SW1#sh int e0/0 switch
Name: Et0/0
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Operational Dot1q Ethertype:  0x8100
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 20 (Inactive)
Administrative Native VLAN tagging: enabled
Operational Native VLAN tagging: disabled
...

SW1#sh int trunk
Port                Mode         Encapsulation  Status        Native vlan
Et0/0               on              802.1q            trunking      20

Port                Vlans allowed on trunk
Et0/0               1-4094

Port                Vlans allowed and active in management domain
Et0/0               1

Port                Vlans in spanning tree forwarding state and not pruned
Et0/0               1

SW2#sh int e0/0 swit
Name: Et0/0
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Operational Dot1q Ethertype:  0x8100
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 20 (Inactive)
Administrative Native VLAN tagging: enabled
Operational Native VLAN tagging: disabled
...

SW2#sh int trun
Port                Mode         Encapsulation  Status        Native vlan
Et0/0               on              802.1q           trunking      20

Port                Vlans allowed on trunk
Et0/0               1-4094

Port                Vlans allowed and active in management domain
Et0/0               1

Port                Vlans in spanning tree forwarding state and not pruned
Et0/0               1

Lab 3. Switching - 802.1q Trunk Ports

Objective: Configure an 802.1q trunk between SW1 and SW2


SW1:
SW1(config)#default int e0/0                        ----> to restore int e0/0 to default setting
SW1(config)#int e0/0
SW1(config-if)#switchport mode dynamic desirable
SW1(config-if)#no shu

SW2: 
SW2(config)#int e0/0
SW2(config-if)#switchport trunk encapsulation dot1q
SW2(config-if)#switc mode trun
SW2(config-if)#no shut

Verify the switchport and trunk

SW1(config-if)#do sh int e0/0 switch
Name: Et0/0
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: dot1q
Operational Dot1q Ethertype:  0x8100
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Operational Native VLAN tagging: disabled
  
SW1(config-if)#do sh int statu | i Port|Et0/0
Port         Name               Status       Vlan       Duplex  Speed Type
Et0/0                               connected    trunk        auto   auto   10BaseTX

SW1(config-if)#do sh int e0/0 switch        
Name: Et0/0
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: dot1q
Operational Dot1q Ethertype:  0x8100
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Operational Native VLAN tagging: disabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
 ...

SW1(config-if)#do sh int trunk              
Port                Mode         Encapsulation  Status        Native vlan
Et0/0               desirable    n-802.1q       trunking      1

Port                Vlans allowed on trunk
Et0/0               1-4094

Port                Vlans allowed and active in management domain
Et0/0               1

Port                Vlans in spanning tree forwarding state and not pruned
Et0/0               1

SW2(config-if)#do sh int status | i Port|Et0/0
Port         Name               Status          Vlan       Duplex  Speed Type
Et0/0                                connected    trunk        auto   auto  10BaseTX

SW2(config-if)#do sh int e0/0 switch
Name: Et0/0
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Operational Dot1q Ethertype:  0x8100
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Operational Native VLAN tagging: disabled
...
  
SW2(config-if)#do sh int trun
Port                Mode         Encapsulation  Status        Native vlan
Et0/0               on              802.1q            trunking        1

Port                Vlans allowed on trunk
Et0/0               1-4094

Port                Vlans allowed and active in management domain
Et0/0               1

Port                Vlans in spanning tree forwarding state and not pruned
Et0/0               1

Lab 2. Switching - ISL Trunk Ports

Objective: Configure an ISL trunk between SW1 and SW2


SW1:
SW1(config)#int e0/0
SW1(config-if)#switchport mode dynamic desirable
SW1(config-if)#no shu

SW2: 
SW2(config)#int e0/0
SW2(config-if)#switchport mode dynamic desirable
SW2(config-if)#no shu

Verify the switchport and trunk

SW1(config-if)#do sh int statu | in Port|Et0/0
Port         Name               Status       Vlan       Duplex  Speed Type
Et0/0                           connected    trunk        auto      auto    10BaseTX

SW2(config-if)#do sh int status | i (Port|Et0/0)
Port         Name               Status       Vlan       Duplex  Speed Type
Et0/0                           connected    trunk        auto      auto    10BaseTX

SW2(config-if)#do sh int e0/0 switch
Name: Et0/0
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: isl
Operational Dot1q Ethertype:  0x8100
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Operational Native VLAN tagging: disabled

SW2(config-if)#do sh int trunk
Port                Mode          Encapsulation  Status        Native vlan
Et0/0               desirable     n-isl                 trunking      1

Port                Vlans allowed on trunk
Et0/0               1-4094

Port                Vlans allowed and active in management domain
Et0/0               1

Port                Vlans in spanning tree forwarding state and not pruned
Et0/0               1

Lab 1. Switching - Layer 2 Acess Switchports

Objective: Configure layer 2 connectivity between R1 and R2 via SW1 (Switch/Catalyst)

R1#

interface Ethernet0/0
 ip address 12.12.12.1 255.255.255.0

R2#
interface Ethernet0/0
 ip address 12.12.12.1 255.255.255.0

SW1#
SW1(config)#int e0/0
SW1(config-if)#switchport                        ----> by default switch already in switchport mode
SW1(config-if)#switchport mode dynamic desirable
SW1(config-if)#des to-R1

SW1(config-if)#int e0/1
SW1(config-if)#switchport mode access
SW1(config-if)#des to-R2

Verify the switchport in SW1

SW1(config-if)#do sh int status | i Port|Et0/0|Et0/1
Port         Name               Status       Vlan       Duplex  Speed Type
Et0/0        to-R1              connected    1            auto    auto 10BaseTX
Et0/1        to-R2              connected    1            auto    auto 10BaseTX

SW1(config-if)#do sh int e0/0 switchport
Name: Et0/0
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
...

SW1(config-if)#do sh int e0/1 switchport
Name: Et0/1
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
...

Make sure the ping is ok! 

R1#sh ip int brie
Interface                    IP-Address      OK? Method Status            Protocol
Ethernet0/0                12.12.12.1       YES manual   up                    up       
         
R1#ping 12.12.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Monday, January 2, 2012

Lab 10. Frame Relay Bridging



R1#
bridge irb
bridge 1 protocol ieee
bridge 1 route ip
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 bridge-group 1
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 frame-relay map bridge 102 broadcast
 bridge-group 1
!
interface BVI1
 ip address 12.12.12.11 255.255.255.0

R2#
bridge irb
bridge 1 protocol ieee
bridge 1 route ip

interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 bridge-group 1
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 frame-relay map bridge 201 broadcast

interface BVI1
 ip address 12.12.12.12 255.255.255.0

FR#
frame-relay switching
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 frame-relay lmi-type cisco
 frame-relay intf-type dce
 frame-relay route 102 interface Serial0/1 201
!
interface Serial0/1
 no ip address
 encapsulation frame-relay
 clock rate 2000000
 frame-relay lmi-type cisco
 frame-relay intf-type dce
 frame-relay route 201 interface Serial0/0 102

Check frame-relay mapping

R1(config-if)#do sh fram map  
Serial0/0 (up): bridge dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active

R2(config-if)# do sh fram map
Serial0/0 (up): bridge dlci 201(0xC9,0x3090), static,
              broadcast,
              CISCO, status defined, active

I think my lucky day on April! Yes 25 April 2012

After thinking a while, finally I change my lab date to 25 April 2012 in Hongkong.

The reason is I am too lazy to study. No big difference taking in April, May, or even in December 2012. I will study after pay the lab which is 90 days before exam :)

So, let's go April... Let's make the dream come true

~ CCIE Wannabe ~