My Countingdown

Friday, December 16, 2011

Lab 6. MPLS – PE – CE BGP Routing




Now we want to establish connection between PE and CE using BGP.
Let’s take example BNI. We have new customer BNI want to connect to our MPLS backbone using BGP to PE.

To do this lab, you need to do Lab-1 http://pursuingmydestiny.blogspot.com/2011/12/lab-1-mpls-backbone.html for establishing MPLS backbone and Lab-2 first http://pursuingmydestiny.blogspot.com/2011/12/lab-2-mpls-vpn.html for establishing MP-BGP only.

PE1#
ip vrf BNI
 rd 65000:5
 route-target export 65000:5
 route-target import 65000:5
!
interface Serial0/0
 ip vrf forwarding BNI
 ip address 192.168.3.1 255.255.255.252
!
router bgp 65000
 address-family ipv4 vrf BNI
  neighbor 192.168.3.2 remote-as 100
  neighbor 192.168.3.2 activate
  neighbor 192.168.3.2 as-override

PE2#
ip vrf BNI
 rd 65000:5
 route-target export 65000:5
 route-target import 65000:5
!
interface Serial0/0
 ip vrf forwarding BNI
 ip address 192.168.3.5 255.255.255.252
!
router bgp 65000
 address-family ipv4 vrf BNI
  neighbor 192.168.3.6 remote-as 100
  neighbor 192.168.3.6 activate
  neighbor 192.168.3.6 as-override

BNI1#
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface Serial0/0
 ip address 192.168.3.2 255.255.255.252
!
router bgp 100
 network 6.6.6.6 mask 255.255.255.255
 neighbor 192.168.3.1 remote-as 65000

BNI2#
interface Loopback0
 ip address 66.66.66.66 255.255.255.252
!
interface Serial0/0
 ip address 192.168.3.6 255.255.255.252
!
router bgp 100
 network 66.66.66.66 mask 255.255.255.255
 neighbor 192.168.3.5 remote-as 65000

Let’s check vpn BNI in PE

PE2(config-router-af)#do sh ip bgp vpnv4 vrf BNI
BGP table version is 24, local router ID is 10.10.10.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 65000:5 (default for vrf BNI)
*>i6.6.6.6/32       10.10.10.1               0    100      0 100 i
*> 66.66.66.66/32   192.168.3.6              0             0 100 i

Let’s check routing table in PE and CE (BNI2)

PE2(config-router-af)#do sh ip rou vrf BNI

Routing Table: BNI
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     66.0.0.0/32 is subnetted, 1 subnets
B       66.66.66.66 [20/0] via 192.168.3.6, 00:01:42
     6.0.0.0/32 is subnetted, 1 subnets
B       6.6.6.6 [200/0] via 10.10.10.1, 00:01:33
     192.168.3.0/30 is subnetted, 1 subnets
C       192.168.3.4 is directly connected, Serial0/0

BNI2#SH IP ROU
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     66.0.0.0/32 is subnetted, 1 subnets
C       66.66.66.66 is directly connected, Loopback0
     6.0.0.0/32 is subnetted, 1 subnets
B       6.6.6.6 [20/0] via 192.168.3.5, 00:01:54
     192.168.3.0/30 is subnetted, 1 subnets
C       192.168.3.4 is directly connected, Serial0/0

Let’s do ping from R2 to R1 and do trace route also

BNI2#ping 6.6.6.6 sou 66.66.66.66

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
Packet sent with a source address of 66.66.66.66
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/94/112 ms

BNI2#trac 6.6.6.6 sou 66.66.66.66
Type escape sequence to abort.
Tracing the route to 6.6.6.6

  1 192.168.3.5 60 msec 40 msec 52 msec
  2 192.168.20.1 [MPLS: Labels 17/32 Exp 0] 100 msec 116 msec 112 msec
  3 192.168.3.1 [MPLS: Label 32 Exp 0] 76 msec 80 msec 136 msec
  4 192.168.3.2 104 msec 100 msec *

No comments:

Post a Comment