My Countingdown

Thursday, December 8, 2011

Lab 1. EIGRP - Configuration


R1#
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 100.100.100.1 255.255.255.255
!
interface Loopback2
ip address 200.200.200.1 255.255.255.255
!
interface Loopback3
ip address 30.30.30.1 255.255.255.255
!
interface Serial0/0
ip address 12.12.12.1 255.255.255.0
!
router eigrp 10
network 1.1.1.1 0.0.0.0
network 12.12.12.1 0.0.0.0
no auto-summary
!
router ospf 1
log-adjacency-changes
network 30.30.30.1 0.0.0.0 area 0
!
router rip
version 2
network 200.200.200.0

R2#
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.2 255.255.255.0
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
!
router eigrp 10
network 2.2.2.2 0.0.0.0
network 12.12.12.2 0.0.0.0
network 23.23.23.2 0.0.0.0
no auto-summary

R3#
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 10.0.0.1 255.255.255.255
!
interface Loopback2
ip address 10.0.0.2 255.255.255.255
!
interface Loopback3
ip address 10.0.0.3 255.255.255.255
!
interface Loopback4
ip address 10.0.0.4 255.255.255.255
!
interface Loopback5
ip address 10.0.0.5 255.255.255.255
!
interface Loopback6
ip address 10.0.0.6 255.255.255.255
!
interface Loopback7
ip address 10.0.0.7 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
!
router eigrp 10
network 3.3.3.3 0.0.0.0
network 10.0.0.1 0.0.0.0
network 10.0.0.2 0.0.0.0
network 10.0.0.3 0.0.0.0
network 10.0.0.4 0.0.0.0
network 10.0.0.5 0.0.0.0
network 10.0.0.6 0.0.0.0
network 10.0.0.7 0.0.0.0
network 23.23.23.3 0.0.0.0
no auto-summary

Check the route & EIGRP topology

R1(config-if)#do sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

  200.200.200.0/32 is subnetted, 1 subnets
C    200.200.200.1 is directly connected, Loopback2
  1.0.0.0/32 is subnetted, 1 subnets
C    1.1.1.1 is directly connected, Loopback0
  2.0.0.0/32 is subnetted, 1 subnets
D    2.2.2.2 [90/2297856] via 12.12.12.2, 00:01:06, Serial0/0
  100.0.0.0/32 is subnetted, 1 subnets
C    100.100.100.1 is directly connected, Loopback1
  3.0.0.0/32 is subnetted, 1 subnets
D    3.3.3.3 [90/2323456] via 12.12.12.2, 00:01:02, Serial0/0
  23.0.0.0/24 is subnetted, 1 subnets
D    23.23.23.0 [90/2195456] via 12.12.12.2, 00:01:08, Serial0/0
  10.0.0.0/32 is subnetted, 7 subnets
D    10.0.0.2 [90/2323456] via 12.12.12.2, 00:01:05, Serial0/0
D    10.0.0.3 [90/2323456] via 12.12.12.2, 00:01:05, Serial0/0
D    10.0.0.1 [90/2323456] via 12.12.12.2, 00:01:05, Serial0/0
D    10.0.0.6 [90/2323456] via 12.12.12.2, 00:01:05, Serial0/0
D    10.0.0.7 [90/2323456] via 12.12.12.2, 00:01:05, Serial0/0
D    10.0.0.4 [90/2323456] via 12.12.12.2, 00:01:05, Serial0/0
D    10.0.0.5 [90/2323456] via 12.12.12.2, 00:01:05, Serial0/0
  12.0.0.0/24 is subnetted, 1 subnets
C    12.12.12.0 is directly connected, Serial0/0
  30.0.0.0/32 is subnetted, 1 subnets
C    30.30.30.1 is directly connected, Loopback3

Check EIGRP neighbor and EIGRP topology

R1#sh ip eigrp nei
IP-EIGRP neighbors for process 10
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 12.12.12.2 Se0/0 14 00:01:47 68 612 0 13

R1#sh ip eigrp topol
IP-EIGRP Topology Table for AS(10)/ID(200.200.200.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 3.3.3.3/32, 1 successors, FD is 2323456
   via 12.12.12.2 (2323456/409600), Serial0/0
P 2.2.2.2/32, 1 successors, FD is 2297856
   via 12.12.12.2 (2297856/128256), Serial0/0
P 1.1.1.1/32, 1 successors, FD is 128256
   via Connected, Loopback0
P 10.0.0.2/32, 1 successors, FD is 2323456
   via 12.12.12.2 (2323456/409600), Serial0/0
P 10.0.0.3/32, 1 successors, FD is 2323456
   via 12.12.12.2 (2323456/409600), Serial0/0
P 10.0.0.1/32, 1 successors, FD is 2323456
   via 12.12.12.2 (2323456/409600), Serial0/0
P 10.0.0.6/32, 1 successors, FD is 2323456
   via 12.12.12.2 (2323456/409600), Serial0/0
P 12.12.12.0/24, 1 successors, FD is 2169856
   via Connected, Serial0/0
P 10.0.0.7/32, 1 successors, FD is 2323456
   via 12.12.12.2 (2323456/409600), Serial0/0

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status

P 10.0.0.4/32, 1 successors, FD is 2323456
   via 12.12.12.2 (2323456/409600), Serial0/0
P 10.0.0.5/32, 1 successors, FD is 2323456
   via 12.12.12.2 (2323456/409600), Serial0/0
P 23.23.23.0/24, 1 successors, FD is 2195456
  via 12.12.12.2 (2195456/281600), Serial0/0

Check ping availability to loopback R2 & R3

R1(config-if)#do ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/16/44 ms

R1(config-if)#do ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/64/100 ms

No comments:

Post a Comment