Let’s do practice
R1#
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
ip ospf 1 area 0
no shut
R2#
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
ip ospf 1 area 0
no shut
Let’s do traffic shaping on Fa0/0 in R1
R1(config)#int f0/0
R1(config-if)#traffic-shape rate ?
<8000-100000000> Target Bit Rate (bits per second)
R1(config-if)#traffic-shape rate 128000 ?
<0-100000000> bits per interval, sustained
<cr>
R1(config-if)#traffic-shape rate 128000 8000 ?
<0-100000000> bits per interval, excess in first interval
<cr>
R1(config-if)#traffic-shape rate 128000 8000 0 ?
<0-4096> Set buffer limit
<cr>
R1(config-if)#traffic-shape rate 128000 8000 0 1000
Verify the traffic-shaping
R1(config-if)#do ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/39/56 ms
R1#show traffic-shape f0/0
Interface Fa0/0
Access Target Byte Sustain Excess Interval Increment Adapt
VC List Rate Limit bits/int bits/int (ms) (bytes) Active
- 128000 1000 8000 0 62 1000 -
R1#show traffic-shape stat
Acc. Queue Packets Bytes Packets Bytes Shaping
I/F List Depth Delayed Delayed Active
Fa0/0 0 27 2605 0 0 no
No comments:
Post a Comment