My Countingdown

Thursday, December 8, 2011

Lab 6. RIP Filtering – Administrative Distance


R1#
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
ip address 12.12.12.1 255.255.255.0
!
router rip
version 2
network 1.0.0.0
network 12.0.0.0
no auto-summary

R2#
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.2 255.255.255.0
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
!
router rip
version 2
network 2.0.0.0
network 12.0.0.0
network 23.0.0.0
no auto-summary

R3#
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
!
router rip
version 2
network 3.0.0.0
network 23.0.0.0
no auto-summary

Let's check the routing table

R1(config-router)#do sh ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

  1.0.0.0/32 is subnetted, 1 subnets
C    1.1.1.1 is directly connected, Loopback0
  2.0.0.0/32 is subnetted, 1 subnets
R    2.2.2.2 [120/1] via 12.12.12.2, 00:00:10, Serial0/0
  3.0.0.0/32 is subnetted, 1 subnets
R    3.3.3.3 [120/2] via 12.12.12.2, 00:00:10, Serial0/0
  23.0.0.0/24 is subnetted, 1 subnets
R    23.23.23.0 [120/1] via 12.12.12.2, 00:00:10, Serial0/0
  12.0.0.0/24 is subnetted, 1 subnets
C    12.12.12.0 is directly connected, Serial0/0

R1(config-router)#do sh ip rout 3.3.3.3
Routing entry for 3.3.3.3/32
Known via "rip", distance 120, metric 2
Redistributing via rip
Last update from 12.12.12.2 on Serial0/0, 00:00:19 ago
Routing Descriptor Blocks:
* 12.12.12.2, from 12.12.12.2, 00:00:19 ago, via Serial0/0
Route metric is 2, traffic share count is 1

R1(config-router)#do ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/41/80 ms

Then we will make AD for 3.3.3.3 to 255 in order to be unaccessible to 3.3.3.3

R1(config-router)#distance 255 0.0.0.0 255.255.255.255 ?
<1-99> IP Standard access list number
<1300-1999> IP Standard expanded access list number
WORD Standard access-list name

R1(config-router)#distance 255 0.0.0.0 255.255.255.255 1
R1(config-router)#exi
R1(config)#access 1 permit host 3.3.3.3


Check the routing table. 3.3.3.3 should not be in routing table and can not be ping.


R1(config)#do clear ip rout *
R1(config)#do sh ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

  1.0.0.0/32 is subnetted, 1 subnets
C    1.1.1.1 is directly connected, Loopback0
  2.0.0.0/32 is subnetted, 1 subnets
R    2.2.2.2 [120/1] via 12.12.12.2, 00:00:07, Serial0/0
  23.0.0.0/24 is subnetted, 1 subnets
R    23.23.23.0 [120/1] via 12.12.12.2, 00:00:07, Serial0/0
  12.0.0.0/24 is subnetted, 1 subnets
C    12.12.12.0 is directly connected, Serial0/0


R1(config)#do ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)


R1(config)#do sh ip rip database 3.3.3.3 255.255.255.255
%Route not in database

No comments:

Post a Comment