R1#
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
ip address 123.123.123.1 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
frame-relay map ip 123.123.123.2 102
frame-relay map ip 123.123.123.3 103
no frame-relay inverse-arp
!
router ospf 1
router-id 1.1.1.1
network 0.0.0.0 255.255.255.255 area 0
R2#
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
ip address 123.123.123.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
frame-relay map ip 123.123.123.1 201
frame-relay map ip 123.123.123.3 201
no frame-relay inverse-arp
!
router ospf 2
router-id 2.2.2.2
network 0.0.0.0 255.255.255.255 area 0
R3#
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
ip address 123.123.123.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint
frame-relay map ip 123.123.123.1 301
frame-relay map ip 123.123.123.2 301
no frame-relay inverse-arp
!
router ospf 3
router-id 3.3.3.3
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
Let’s check the mapping and OSPF type
R1(config-router)#do sh fram map
Serial0/0 (up): ip 123.123.123.2 dlci 102(0x66,0x1860), static,
CISCO, status defined, active
Serial0/0 (up): ip 123.123.123.3 dlci 103(0x67,0x1870), static,
CISCO, status defined, active
R1(config-router)#do sh ip ospf int s0/0
Serial0/0 is up, line protocol is up
Internet Address 123.123.123.1/24, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_MULTIPOINT, Cost: 64
Let’s check the ospf neighbor
R1(config-router)#do sh ip ospf nei
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ - 00:01:57 123.123.123.2 Serial0/0
3.3.3.3 0 FULL/ - 00:01:57 123.123.123.3 Serial0/0
From OSPF neighbor, OSPF Point-to-Multipoint no DR/BFR elected. Let’s check the routing table and make sure the ping is ok
R3(config)#do sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/65] via 123.123.123.1, 00:03:20, Serial0/0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/129] via 123.123.123.1, 00:03:10, Serial0/0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
123.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O 123.123.123.2/32 [110/128] via 123.123.123.1, 00:03:10, Serial0/0
O 123.123.123.1/32 [110/64] via 123.123.123.1, 00:03:20, Serial0/0
C 123.123.123.0/24 is directly connected, Serial0/0
R3(config)#do ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/19/52 ms
R3(config)#do ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/26/80 ms
No comments:
Post a Comment