My Countingdown

Tuesday, December 13, 2011

Lab 9. OSPF Network Broadcast



Before we already make OSPF adjacency using ‘neighbor xxx’ as default frame relay is Non Broadcast. Let’s make another solution using broadcast by adding command ‘ip ospf network broadcast’ in the interface.
  
R1#
int s0/0
  encap frame-relay
  ip addr 123.123.123.1 255.255.255.0
  frame-relay map ip 123.123.123.2 102 broadcast
  frame-relay map ip 123.123.123.3 103 broadcast

int lo0
  ip addr 1.1.1.1 255.255.255.255

R2#
int s0/0
  encap frame-relay
  ip addr 123.123.123.2 255.255.255.0
  frame-relay map ip 123.123.123.1 201 broadcast
  frame-relay map ip 123.123.123.3 201

int lo0
  ip addr 2.2.2.2 255.255.255.255

R3#
int s0/0
   encap frame-relay
   ip addr 123.123.123.3 255.255.255.0


   frame-relay map ip 123.123.123.1 301 broadcast
   frame-relay map ip 123.123.123.2 301
int lo0
   ip addr 3.3.3.3 255.255.255.255

Check frame mapping. It should be active

R1#sh fram map
Serial0/0 (up): ip 123.123.123.2 dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active
Serial0/0 (up): ip 123.123.123.3 dlci 103(0x67,0x1870), static,
              broadcast,
              CISCO, status defined, active

R2(config)#do sh fram map
Serial0/0 (up): ip 123.123.123.1 dlci 201(0xC9,0x3090), static,
              broadcast,
              CISCO, status defined, active
Serial0/0 (up): ip 123.123.123.3 dlci 201(0xC9,0x3090), static,
              CISCO, status defined, active

R3#sh fram map
Serial0/0 (up): ip 123.123.123.2 dlci 301(0x12D,0x48D0), static,
              CISCO, status defined, active
Serial0/0 (up): ip 123.123.123.1 dlci 301(0x12D,0x48D0), static,
              broadcast,
              CISCO, status defined, active

Make sure IP point to point already ok by test ping

R1#ping 123.123.123.2 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/23/52 ms

R1#ping 123.123.123.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/11/28 ms

R2(config)#do ping 123.123.123.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/19/52 ms

R2(config)#do ping 123.123.123.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/31/92 ms

Now, lets configure OSPF so the ip loopback can be ping

R1(config)#router ospf 1
R1(config-router)#network 1.1.1.1 0.0.0.0 area 0
R1(config-router)#network 123.123.123.1 0.0.0.0 area 0

R2(config)#router ospf 2
R2(config-router)#network 2.2.2.2 0.0.0.0 area 0
R2(config-router)#network 123.123.123.2 0.0.0.0 area 0

R3(config-if)#router ospf 3
R3(config-router)#network 3.3.3.3 0.0.0.0 area 0
R3(config-router)#network 123.123.123.3 0.0.0.0 area 0

Let’s make the OSPF to broadcast type

R1(config-router)#int s0/0
R1(config-if)#ip ospf network broadcast

R2(config-router)#int s0/0
R2(config-if)#ip ospf net broadc

R3(config-router)#int s0/0
R3(config-if)#ip ospf net broad

And make sure R1 is DR as hub!

R1(config-router)#int s0/0
R1(config-if)#ip ospf prio 255

R2(config-router)#int s0/0
R2(config-if)#ip ospf prio 0

R3(config-router)#int s0/0
R3(config-if)#ip ospf prio 0

Let’s check the routing table!

R2(config-if)#do sh ip ospf nei
Neighbor ID     Pri    State                 Dead Time   Address            Interface
1.1.1.1              255   FULL/DR         00:00:39     123.123.123.1   Serial0/0

R2(config-if)#do sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/65] via 123.123.123.1, 00:01:00, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/65] via 123.123.123.3, 00:01:00, Serial0/0
     123.0.0.0/24 is subnetted, 1 subnets
C       123.123.123.0 is directly connected, Serial0/0

R2(config-if)#do ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/13/24 ms

R2(config-if)#do ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/28/92 ms

No comments:

Post a Comment