My Countingdown

Thursday, December 8, 2011

Lab 11. Frame Relay End to End Keepalive


This lab to show if we have 2 links with the same source and destination where one only using Serial and another using Frame Relay. We want the frame relay is as the main. Then if frame relay down, the backup will take over the traffic

R1#
interface Serial0/0
no ip address
encapsulation frame-relay

interface Serial0/0.1 point-to-point
backup interface Serial0/1
ip address 12.12.12.1 255.255.255.0
frame-relay interface-dlci 102
class KEEP_ALIVE

interface Serial0/1
ip address 21.21.21.1 255.255.255.0

router eigrp 1
network 0.0.0.0
auto-summary

map-class frame-relay KEEP_ALIVE
frame-relay end-to-end keepalive mode bidirectional

R2#
interface Serial0/0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp

interface Serial0/0.1 point-to-point
ip address 12.12.12.2 255.255.255.0
frame-relay interface-dlci 201
class KEEP_ALIVE

interface Serial0/1
ip address 21.21.21.2 255.255.255.0

router eigrp 1
network 0.0.0.0
auto-summary

map-class frame-relay KEEP_ALIVE
frame-relay end-to-end keepalive mode bidirectional

Check frame keep alive

R1#sh fram end keepaliv
End-to-end Keepalive Statistics for Interface Serial0/0 (Frame Relay DTE)

DLCI = 102, DLCI USAGE = LOCAL, VC STATUS = ACTIVE (EEK UP)

SEND SIDE STATISTICS
Send Sequence Number: 52, Receive Sequence Number: 53
Configured Event Window: 3, Configured Error Threshold: 2
Total Observed Events: 55, Total Observed Errors: 0
Monitored Events: 3, Monitored Errors: 0
Successive Successes: 3, End-to-end VC Status: UP

RECEIVE SIDE STATISTICS
Send Sequence Number: 53, Receive Sequence Number: 52
Configured Event Window: 3, Configured Error Threshold: 2
Total Observed Events: 54, Total Observed Errors: 0
Monitored Events: 3, Monitored Errors: 0
Successive Successes: 3, End-to-end VC Status: UP

R1#sh int des
Interface Status              Protocol      Description
Fa0/0     admin down     down
Se0/0     up                    up
Se0/0.1  up                    up
Fa0/1     admin down     down
Se0/1     standby mode  down

R1#sh ip int brie
Interface              IP-Address  OK?  Method     Status                          Protocol
FastEthernet0/0   unassigned   YES   NVRAM   administratively down  down
Serial0/0             unassigned   YES    NVRAM   up                               up
Serial0/0.1          12.12.12.1  YES    NVRAM   up                               up
FastEthernet0/1   unassigned  YES    NVRAM   administratively down  down
Serial0/1             21.21.21.1  YES    NVRAM   standby mode             down

R2#sh fram end keep
End-to-end Keepalive Statistics for Interface Serial0/0 (Frame Relay DTE)

DLCI = 201, DLCI USAGE = LOCAL, VC STATUS = ACTIVE (EEK UP)
SEND SIDE STATISTICS

Send Sequence Number: 65, Receive Sequence Number: 66
Configured Event Window: 3, Configured Error Threshold: 2
Total Observed Events: 68, Total Observed Errors: 0
Monitored Events: 3, Monitored Errors: 0
Successive Successes: 3, End-to-end VC Status: UP

RECEIVE SIDE STATISTICS
Send Sequence Number: 66, Receive Sequence Number: 65
Configured Event Window: 3, Configured Error Threshold: 2
Total Observed Events: 68, Total Observed Errors: 0
Monitored Events: 3, Monitored Errors: 0
Successive Successes: 3, End-to-end VC Status: UP

R2#sh int des
Interface Status              Protocol Description
Fa0/0      admin down    down
Se0/0      up                   up
Se0/0.1   up                   up
Fa0/1      admin down    down
Se0/1      up                  down

R2#sh ip int bri
Interface               IP-Address  OK? Method   Status                        Protocol
FastEthernet0/0    unassigned    YES NVRAM administratively down down
Serial0/0               unassigned   YES NVRAM up                               up
Serial0/0.1           12.12.12.2   YES NVRAM up                               up
FastEthernet0/1    unassigned   YES NVRAM administratively down  down
Serial0/1               21.21.21.2  YES NVRAM up                               down

Let’s test is the backup work! Do shutdown interface s0/0 in R2

R2(config)#int s0/0
R2(config-if)#shut
R2(config-if)#
*Mar 1 00:15:07.311: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 12.12.12.1 (Serial0/0.1) is down: interface down
*Mar 1 00:15:09.283: %LINK-5-CHANGED: Interface Serial0/0, changed state to administratively down
*Mar 1 00:15:10.283: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to down

Wait a second the backup interface will going to up!

R2#
*Mar 1 00:15:47.503: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up
*Mar 1 00:15:47.959: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 21.21.21.1 (Serial0/1) is up: new adjacency


R1#
*Mar 1 00:15:17.035: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 12.12.12.2 (Serial0/0.1) is down: holding time expired
*Mar 1 00:15:29.563: %FR_EEK-5-FAILED: Interface Serial0/0.1 - DLCI 102

In R1, int s0/1 will going to up as before the status is standby mode

*Mar 1 00:15:31.971: %LINK-3-UPDOWN: Interface Serial0/1, changed state to up
*Mar 1 00:15:32.979: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up

*Mar 1 00:15:46.991: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 21.21.21.2 (Serial0/1) is up: new adjacency

R1#sh fram end keepaliv
End-to-end Keepalive Statistics for Interface Serial0/0 (Frame Relay DTE)

DLCI = 102, DLCI USAGE = LOCAL, VC STATUS = ACTIVE (EEK DOWN)

SEND SIDE STATISTICS
Send Sequence Number: 100, Receive Sequence Number: 84
Configured Event Window: 3, Configured Error Threshold: 2
Total Observed Events: 102, Total Observed Errors: 16
Monitored Events: 3, Monitored Errors: 3
Successive Successes: 0, End-to-end VC Status: DOWN

RECEIVE SIDE STATISTICS
Send Sequence Number: 84, Receive Sequence Number: 83
Configured Event Window: 3, Configured Error Threshold: 2
Total Observed Events: 96, Total Observed Errors: 11
Monitored Events: 3, Monitored Errors: 3
Successive Successes: 0, End-to-end VC Status: DOWN
Failures Since Started: 1, Last Failure: 00:02:29

R1#sh ip int brie
Interface            IP-Address OK? Method Status                        Protocol
FastEthernet0/0 unassigned YES NVRAM administratively down down
Serial0/0           unassigned YES NVRAM up                              up
Serial0/0.1        12.12.12.1 YES NVRAM down                        down
FastEthernet0/1 unassigned YES NVRAM administratively down down
Serial0/1           21.21.21.1 YES NVRAM up                              up

R2#sh fram end keep
End-to-end Keepalive Statistics for Interface Serial0/0 (Frame Relay DTE)

R2#sh ip int bri
Interface            IP-Address OK? Method   Status                        Protocol
FastEthernet0/0 unassigned   YES NVRAM administratively down down
Serial0/0           unassigned   YES NVRAM administratively down down
Serial0/0.1        12.12.12.2  YES NVRAM administratively down down
FastEthernet0/1 unassigned  YES NVRAM administratively down down
Serial0/1           21.21.21.2  YES NVRAM up                              up

Without this, the backup interface will be still in standby mode!

No comments:

Post a Comment