- Not So Stubby Area (NSSA) like stub area that no LSA type 4 and LSA type 5. The difference is in NSSA external route is still accepted.
- Because in NSSA, LSA type 5 is rejected so external route change to LSA type 7 instead of LSA type 5.
- NSSA need to be configured in all router within NSSA area
For topology and basic configuration, please refer to http://pursuingmydestiny.blogspot.com/2011/12/lab-3-ospf-standard-area.html.
Let's add new loopback that will be advertised in RIP (saw as external route in OSPF).
R3#
interface Loopback1
ip address 33.33.33.1 255.255.255.255
interface Loopback2
ip address 33.33.33.2 255.255.255.255
interface Loopback3
ip address 33.33.33.3 255.255.255.255
router rip
version 2
network 33.0.0.0
no auto-summary
router ospf 3
redistribute rip subnets
Then configure NSSA in area 1
R2(config-router)#router ospf 2
R2(config-router)#area 1 nssa
R3(config-router)#router ospf 3
R3(config-router)#area 1 nssa
Check the routing table in R3 and R1
R3(config-router)#do sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/75] via 23.23.23.2, 00:01:41, FastEthernet0/0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/11] via 23.23.23.2, 00:01:41, FastEthernet0/0
100.0.0.0/32 is subnetted, 3 subnets
O IA 100.100.100.1 [110/75] via 23.23.23.2, 00:01:41, FastEthernet0/0
O IA 100.100.100.2 [110/75] via 23.23.23.2, 00:01:41, FastEthernet0/0
O IA 100.100.100.3 [110/75] via 23.23.23.2, 00:01:41, FastEthernet0/0
33.0.0.0/32 is subnetted, 3 subnets
C 33.33.33.1 is directly connected, Loopback1
C 33.33.33.3 is directly connected, Loopback3
C 33.33.33.2 is directly connected, Loopback2
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
23.0.0.0/24 is subnetted, 1 subnets
C 23.23.23.0 is directly connected, FastEthernet0/0
12.0.0.0/24 is subnetted, 1 subnets
O IA 12.12.12.0 [110/74] via 23.23.23.2, 00:01:44, FastEthernet0/0
R1(config)#do sh ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O IA 2.2.2.2 [110/65] via 12.12.12.2, 00:09:45, Serial0/0
100.0.0.0/32 is subnetted, 7 subnets
C 100.100.100.4 is directly connected, Loopback4
C 100.100.100.5 is directly connected, Loopback5
C 100.100.100.6 is directly connected, Loopback6
C 100.100.100.7 is directly connected, Loopback7
C 100.100.100.1 is directly connected, Loopback1
C 100.100.100.2 is directly connected, Loopback2
C 100.100.100.3 is directly connected, Loopback3
33.0.0.0/32 is subnetted, 3 subnets
O E2 33.33.33.1 [110/20] via 12.12.12.2, 00:01:05, Serial0/0
O E2 33.33.33.3 [110/20] via 12.12.12.2, 00:01:05, Serial0/0
O E2 33.33.33.2 [110/20] via 12.12.12.2, 00:01:05, Serial0/0
3.0.0.0/32 is subnetted, 1 subnets
O IA 3.3.3.3 [110/75] via 12.12.12.2, 00:01:10, Serial0/0
23.0.0.0/24 is subnetted, 1 subnets
O IA 23.23.23.0 [110/74] via 12.12.12.2, 00:01:10, Serial0/0
12.0.0.0/24 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, Serial0/0
Now we see external route RIP from R3 already in R1.
Check the ping from R1
R1(config)#do ping 33.33.33.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/46/68 ms
R1(config)#do ping 33.33.33.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/43/80 ms
R1(config)#do ping 33.33.33.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/44/76 ms
Now check ping from R3 to 100.100.100.4-100.100.100.7 that advertise from EIGRP in R1
R3(config)#do ping 100.100.100.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.100.100.4, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R3(config)#do ping 100.100.100.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.100.100.5, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
It’s happen because no default route in R3 than it can not ping to those IPs. The solutin using command ‘default-information-originate’.
R2(config-router)#router ospf 2
R2(config-router)#area 1 nssa default-information-originate
Then check again routing table in R3
R3(config)#do sh ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 23.23.23.2 to network 0.0.0.0
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/75] via 23.23.23.2, 00:06:57, FastEthernet0/0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/11] via 23.23.23.2, 00:06:57, FastEthernet0/0
100.0.0.0/32 is subnetted, 3 subnets
O IA 100.100.100.1 [110/75] via 23.23.23.2, 00:06:57, FastEthernet0/0
O IA 100.100.100.2 [110/75] via 23.23.23.2, 00:06:57, FastEthernet0/0
O IA 100.100.100.3 [110/75] via 23.23.23.2, 00:06:57, FastEthernet0/0
33.0.0.0/32 is subnetted, 3 subnets
C 33.33.33.1 is directly connected, Loopback1
C 33.33.33.3 is directly connected, Loopback3
C 33.33.33.2 is directly connected, Loopback2
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
23.0.0.0/24 is subnetted, 1 subnets
C 23.23.23.0 is directly connected, FastEthernet0/0
12.0.0.0/24 is subnetted, 1 subnets
O IA 12.12.12.0 [110/74] via 23.23.23.2, 00:07:01, FastEthernet0/0
O*N2 0.0.0.0/0 [110/1] via 23.23.23.2, 00:00:43, FastEthernet0/0
Now there is default route in R3. Let’s try ping again
R3(config)#do ping 100.100.100.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.100.100.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/37/60 ms
R3(config)#do ping 100.100.100.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.100.100.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/38/56 ms
R3(config)#do ping 100.100.100.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.100.100.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/47/88 ms
R3(config)#do ping 100.100.100.7
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.100.100.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/42/64 ms
No comments:
Post a Comment