My Countingdown

Thursday, December 8, 2011

Lab 12. Frame Relay – Multilink PPP



We can use authentication in frame relay using PPP over frame relay. Besides, we can bundle some links with PPP multilink

R1#
username R2 password cisco
!
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay interface-dlci 103 ppp Virtual-Template1
!
interface Serial0/1
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay interface-dlci 204 ppp Virtual-Template1
!
interface Virtual-Template1
ip address 12.12.12.1 255.255.255.0
ppp authentication chap
ppp multilink

R2#
username R1 password cisco
!
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay interface-dlci 301 ppp Virtual-Template1
!
interface Serial0/1
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay interface-dlci 402 ppp Virtual-Template1
!
interface Virtual-Template1
ip address 12.12.12.2 255.255.255.0
ppp authentication chap
ppp multilink

FR#
FR#sh run | sec Serial
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 128000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 103 interface Serial0/2 301
interface Serial0/1
no ip address
encapsulation frame-relay
clock rate 128000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 204 interface Serial0/3 402
interface Serial0/2
no ip address
encapsulation frame-relay
clock rate 128000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 301 interface Serial0/0 103
interface Serial0/3
no ip address
encapsulation frame-relay
clock rate 128000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 402 interface Serial0/1 204

Verify the ppp multilink

R1#sh ppp multilink
Virtual-Access4
Bundle name: R2
Remote Username: R2
Remote Endpoint Discriminator: [1] R2
Local Username: R1
Local Endpoint Discriminator: [1] R1
Bundle up for 00:07:18, total bandwidth 200000, load 1/255
Receive buffer limit 24384 bytes, frag timeout 1000 ms
0/0 fragments/bytes in reassembly list
0 lost fragments, 0 reordered
0/0 discarded fragments/bytes, 0 lost received
0x0 received sequence, 0x1 sent sequence
Member links: 2 (max not set, min not set)
Vi1, since 00:07:18
Vi2, since 00:07:18
No inactive multilink interfaces

R2#sh pp mult
Virtual-Access4
Bundle name: R1
Remote Username: R1
Remote Endpoint Discriminator: [1] R1
Local Username: R2
Local Endpoint Discriminator: [1] R2
Bundle up for 00:08:10, total bandwidth 200000, load 1/255
Receive buffer limit 24384 bytes, frag timeout 1000 ms
0/0 fragments/bytes in reassembly list
0 lost fragments, 0 reordered
0/0 discarded fragments/bytes, 0 lost received
0x1 received sequence, 0x0 sent sequence
Member links: 2 (max not set, min not set)
Vi1, since 00:08:11
Vi2, since 00:08:10
No inactive multilink interfaces

R2#sh ip int brie
Interface                IP-Address OK? Method      Status                          Protocol
FastEthernet0/0     unassigned   YES NVRAM    administratively down  down
Serial0/0                unassigned   YES NVRAM    up                               up
FastEthernet0/1     unassigned   YES NVRAM    administratively down  down
Serial0/1                unassigned  YES NVRAM     up                               up
Virtual-Access1    12.12.12.2  YES TFTP           up                               up
Virtual-Template1 12.12.12.2  YES NVRAM     down                          down
Virtual-Access2    12.12.12.2  YES TFTP          up                                up
Virtual-Access3    unassigned  YES unset            down                          down
Virtual-Access4    12.12.12.2 YES TFTP           up                               up

R2#ping 12.12.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/42/64 ms

If we want to use username, we can do:

R1(config)#do sh run int virtual-tem1
Building configuration...

Current configuration : 113 bytes
!
interface Virtual-Template1
ip address 12.12.12.1 255.255.255.0
ppp authentication chap
ppp multilink
end

R1(config)#int virtual-tem1
R1(config-if)#ppp chap hostname Bandung
R1(config-if)#
*Mar 1 00:11:58.867: %LINK-3-UPDOWN: Interface Virtual-Access4, changed state to down
*Mar 1 00:11:59.095: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to down
*Mar 1 00:11:59.111: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to down
*Mar 1 00:11:59.867: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access4, changed state to down
R1(config-if)#username Jakarta password jkt

R2(config)#userna Bandung passw bdg
R2(config)#do sh run int virtual-tem1
Building configuration...
Current configuration : 113 bytes
!
interface Virtual-Template1
ip address 12.12.12.2 255.255.255.0
ppp authentication chap
ppp multilink
end

R2(config)#int virtual-tem1
R2(config-if)#ppp chap hostn Jakarta

Check the multilink!

R1(config)#do sh ppp multi
No active bundles
No inactive multilink interfaces

R2(config-if)#do sh ppp multi
No active bundles
No inactive multilink interfaces

Oups, there is no multilink. It’s because the password is different

R1(config)#username Jakarta password sama
R2(config-if)#userna Bandung passw sama

*Mar 1 00:14:28.491: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up
*Mar 1 00:14:28.587: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access4, changed state to up
*Mar 1 00:14:29.131: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

Now, check again the ppp multilink

R2(config)#do sh ppp multi
Virtual-Access4
Bundle name: Bandung
Remote Username: Bandung
Remote Endpoint Discriminator: [1] Bandung
Local Username: Jakarta
Local Endpoint Discriminator: [1] Jakarta
Bundle up for 00:04:54, total bandwidth 200000, load 1/255
Receive buffer limit 24384 bytes, frag timeout 1000 ms
0/0 fragments/bytes in reassembly list
0 lost fragments, 0 reordered
0/0 discarded fragments/bytes, 0 lost received
0x0 received sequence, 0x0 sent sequence
Member links: 2 (max not set, min not set)
Vi2, since 00:04:54
Vi1, since 00:04:54
No inactive multilink interfaces

R2(config)#do ping 12.12.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/27/48 ms

No comments:

Post a Comment