- BSR is protocol open standard that use pimv2.
- The function of BSR is the same as auto RP i.e. advertise RP to other routers
- No use dense mode because candidate RP and mapping agent is sent via PIM message hop per hop.
- Advantage using BSR can have multiple BSR and multiple RP.
Lets do the lab :)
R1#
ip multicast-routing
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
ip pim sparse-mode
ip ospf 1 area 0
no shu
R2#
ip multicast-routing
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
ip pim sparse-mode
ip ospf 1 area 0
no shu
!
interface FastEthernet0/1
ip address 23.23.23.2 255.255.255.0
ip pim sparse-mode
ip ospf 1 area 0
no shu
R3#
ip multicast-routing
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
no shu
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
ip pim sparse-mode
ip ospf 1 area 0
no shu
For the testing interface lo0 in R1 will join group to ip multicast for example 239.0.0.1 and configure BSR and RP in R1
R1#
int lo0
ip igmp join-group 239.0.0.1
!
ip pim bsr-candidate loopback 0
ip pim rp-candidate loopback 0
Let’s verify the multicast
R1(config)#do sh ip pim rp mapp
PIM Group-to-RP Mappings
This system is a candidate RP (v2)
This system is the Bootstrap Router (v2)
Group(s) 224.0.0.0/4
RP 1.1.1.1 (?), v2
Info source: 1.1.1.1 (?), via bootstrap, priority 0, holdtime 150
Uptime: 00:01:25, expires: 00:02:02
R2(config-if)#do sh ip pim rp map
PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
RP 1.1.1.1 (?), v2
Info source: 1.1.1.1 (?), via bootstrap, priority 0, holdtime 150
Uptime: 00:00:30, expires: 00:01:58
R3(config-if)#do sh ip pim rp mapp
PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
RP 1.1.1.1 (?), v2
Info source: 1.1.1.1 (?), via bootstrap, priority 0, holdtime 150
Uptime: 00:00:36, expires: 00:01:49
R3(config-if)#do sh ip mrou
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 239.0.0.1), 00:00:53/stopped, RP 1.1.1.1, flags: SPF
Incoming interface: FastEthernet0/0, RPF nbr 23.23.23.2
Outgoing interface list: Null
(3.3.3.3, 239.0.0.1), 00:00:39/00:03:04, flags: FT
Incoming interface: Loopback0, RPF nbr 0.0.0.0, Registering
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:00:39/00:02:51
(23.23.23.3, 239.0.0.1), 00:00:40/00:02:32, flags: PFT
Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0
Outgoing interface list: Null
(*, 224.0.1.40), 00:02:09/00:02:30, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 00:02:09/00:02:30
R3(config-if)#do ping 239.0.0.1
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.0.0.1, timeout is 2 seconds:
Reply to request 0 from 12.12.12.1, 120 ms
Reply to request 0 from 12.12.12.1, 120 ms
No comments:
Post a Comment