My Countingdown

Thursday, December 8, 2011

Lab 1. RIP Authentication

Now we did various types of Frame Relay. Let's move to RIP. You can go to for RIP summary http://pursuingmydestiny.blogspot.com/2011/12/day-2-ccie-bootcamp.html


R1#
key chain RIP
key 1
key-string CISCO
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 13.13.13.1 255.255.255.0
!
interface Serial0/0
ip address 12.12.12.1 255.255.255.0
ip rip authentication mode md5
ip rip authentication key-chain RIP
!
router rip
version 2
network 0.0.0.0
no auto-summary
!

R2#
key chain RIP
key 1
key-string CISCO
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.2 255.255.255.0
ip rip authentication mode text --- > by default
ip rip authentication key-chain RIP
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
ip rip authentication mode md5
ip rip authentication key-chain RIP
!
router rip
version 2
network 0.0.0.0
no auto-summary

R3#
key chain RIP
key 1
key-string CISCO
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 13.13.13.3 255.255.255.0
!
interface FastEthernet0/1
ip address 23.23.23.3 255.255.255.0
ip rip authentication key-chain RIP
!
router rip
version 2
network 0.0.0.0
no auto-summary

Now, let's check debugging for authentication. RIP support authentication using clear text and MD5

R1#debug ip rip
RIP protocol debugging is on
R1#
*Mar 1 00:14:57.095: RIP: received packet with MD5 authentication
*Mar 1 00:14:57.095: RIP: received v2 update from 12.12.12.2 on Serial0/0
*Mar 1 00:14:57.099: 2.2.2.2/32 via 0.0.0.0 in 1 hops
*Mar 1 00:14:57.099: 3.3.3.3/32 via 0.0.0.0 in 2 hops
*Mar 1 00:14:57.103: 23.23.23.0/24 via 0.0.0.0 in 1 hops

R3(config)#do debug ip rip
RIP protocol debugging is on
*Mar 1 00:16:27.771: RIP: received packet with text authentication CISCO
*Mar 1 00:16:27.775: RIP: received v2 update from 23.23.23.2 on FastEthernet0/1
*Mar 1 00:16:27.775: 1.1.1.1/32 via 0.0.0.0 in 2 hops
*Mar 1 00:16:27.779: 2.2.2.2/32 via 0.0.0.0 in 1 hops
*Mar 1 00:16:27.783: 12.12.12.0/24 via 0.0.0.0 in 1 hops

Let's check the routing table and ping 

R1#sh ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

    1.0.0.0/32 is subnetted, 1 subnets
C    1.1.1.1 is directly connected, Loopback0
    2.0.0.0/32 is subnetted, 1 subnets
R     2.2.2.2 [120/1] via 12.12.12.2, 00:00:08, Serial0/0
    3.0.0.0/32 is subnetted, 1 subnets
R     3.3.3.3 [120/1] via 13.13.13.3, 00:00:22, FastEthernet0/0
    23.0.0.0/24 is subnetted, 1 subnets
R     23.23.23.0 [120/1] via 13.13.13.3, 00:00:22, FastEthernet0/0
                         [120/1] via 12.12.12.2, 00:00:08, Serial0/0
    12.0.0.0/24 is subnetted, 1 subnets
C     12.12.12.0 is directly connected, Serial0/0
    13.0.0.0/24 is subnetted, 1 subnets
C     13.13.13.0 is directly connected, FastEthernet0/0

R1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 28/44/76 ms
R1#ping 2.2.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/29/76 ms

No comments:

Post a Comment