- Sparse mode use shared-based distribution tree.
- No any flooding multicast traffic and must have RP (rendezvous point).
- Host must send request message to get any multicast traffic.
- RP chosen by:
1. Static RP
2. Auto RP. It’s Cisco proprietary
3. BSR
- Using auto RP, dense mode is used for flooding RP candidate and mapping agent to other router.
- In IPV6 only have sparse mode, no dense mode. That’s why no auto RP in IPv6
Lets do the lab :)
Practice makes perfect, right?
R1#
ip multicast-routing
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
ip pim sparse-mode
ip ospf 1 area 0
R2#
ip multicast-routing
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
ip pim sparse-mode
ip ospf 1 area 0
!
interface FastEthernet0/1
ip address 23.23.23.2 255.255.255.0
ip pim sparse-mode
ip ospf 1 area 0
R3#
ip multicast-routing
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
ip pim sparse-mode
ip ospf 1 area 0
For the testing interface lo0 in R1 will join group to ip multicast for example 239.0.0.1
R1#
int lo0
ip igmp join-group 239.0.0.1
Then we need to choose RP. Let’s make 2.2.2.2 is the RP
R1#
ip pim rp-address 2.2.2.2
R2#
ip pim rp-address 2.2.2.2
R3#
ip pim rp-address 2.2.2.2
Let’s verify the multicast
R1(config-if)#do sh ip pim interface
Address Interface Ver/ Nbr Query DR DR
Mode Count Intvl Prior
1.1.1.1 Loopback0 v2/S 0 30 1 1.1.1.1
12.12.12.1 FastEthernet0/0 v2/S 1 30 1 12.12.12.2
R1(config-if)#do sh ip pim rp mapping
PIM Group-to-RP Mappings
Group(s): 224.0.0.0/4, Static
RP: 2.2.2.2 (?)
R1(config-if)#do sh ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 239.0.0.1), 00:04:36/00:02:49, RP 2.2.2.2, flags: SJCL
Incoming interface: FastEthernet0/0, RPF nbr 12.12.12.2
Outgoing interface list:
Loopback0, Forward/Sparse, 00:04:36/00:02:49
(*, 224.0.1.40), 00:04:36/00:02:52, RP 2.2.2.2, flags: SJCL
Incoming interface: FastEthernet0/0, RPF nbr 12.12.12.2
Outgoing interface list:
Loopback0, Forward/Sparse, 00:04:36/00:02:52
R2(config-if)#do sh ip pim int
Address Interface Ver/ Nbr Query DR DR
Mode Count Intvl Prior
2.2.2.2 Loopback0 v2/S 0 30 1 2.2.2.2
12.12.12.2 FastEthernet0/0 v2/S 1 30 1 12.12.12.2
23.23.23.2 FastEthernet0/1 v2/S 1 30 1 23.23.23.3
R2(config-if)#do sh ip pim rp map
PIM Group-to-RP Mappings
Group(s): 224.0.0.0/4, Static
RP: 2.2.2.2 (?)
R2(config-if)#do sh ip mrou
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 239.0.0.1), 00:02:33/00:03:27, RP 2.2.2.2, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:02:33/00:03:27
(3.3.3.3, 239.0.0.1), 00:00:54/00:03:16, flags: T
Incoming interface: FastEthernet0/1, RPF nbr 23.23.23.3
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:00:54/00:03:27
(23.23.23.3, 239.0.0.1), 00:00:56/00:03:15, flags: T
Incoming interface: FastEthernet0/1, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:00:56/00:03:26
(*, 224.0.1.40), 00:11:56/00:03:24, RP 2.2.2.2, flags: SJCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/1, Forward/Sparse, 00:02:17/00:03:03
FastEthernet0/0, Forward/Sparse, 00:02:36/00:03:23
Loopback0, Forward/Sparse, 00:11:57/00:02:26
R3(config-if)#do sh ip pim int
Address Interface Ver/ Nbr Query DR DR
Mode Count Intvl Prior
3.3.3.3 Loopback0 v2/S 0 30 1 3.3.3.3
23.23.23.3 FastEthernet0/0 v2/S 1 30 1 23.23.23.3
R3(config-if)#do sh ip pim rp map
PIM Group-to-RP Mappings
RP: 2.2.2.2 (?)
R3(config-if)#do sh ip mrou
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 239.0.0.1), 00:00:35/stopped, RP 2.2.2.2, flags: SPF
Incoming interface: FastEthernet0/0, RPF nbr 23.23.23.2
Outgoing interface list: Null
(3.3.3.3, 239.0.0.1), 00:00:35/00:03:00, flags: FT
Incoming interface: Loopback0, RPF nbr 0.0.0.0, Registering
Outgoing interface list:
FastEthernet0/0, Forward/Sparse, 00:00:35/00:02:54
(23.23.23.3, 239.0.0.1), 00:00:37/00:02:29, flags: PFT
Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0
Outgoing interface list: Null
(*, 224.0.1.40), 00:11:22/00:02:51, RP 2.2.2.2, flags: SJCL
Incoming interface: FastEthernet0/0, RPF nbr 23.23.23.2
Outgoing interface list:
Loopback0, Forward/Sparse, 00:11:22/00:02:51
R3(config-if)#do ping 239.0.0.1
Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.0.0.1, timeout is 2 seconds:
Reply to request 0 from 12.12.12.1, 80 ms
Reply to request 0 from 12.12.12.1, 116 ms
If the multicast routing not come up, please do ping to ip multicast join-group.
No comments:
Post a Comment