My Countingdown

Tuesday, December 13, 2011

Lab 8. OSPF Network Non Broadcast



Now, let's make example for OSPF Non Broadcast. By default, using Frame Relay is Non broadcast 

R1#
int s0/0
encap frame-relay
ip addr 123.123.123.1 255.255.255.0
frame-relay map ip 123.123.123.2 102 broadcast
frame-relay map ip 123.123.123.3 103 broadcast

int lo0
ip addr 1.1.1.1 255.255.255.255

R2#
int s0/0
  encap frame-relay
  ip addr 123.123.123.2 255.255.255.0
  frame-relay map ip 123.123.123.1 201 broadcast
  frame-relay map ip 123.123.123.3 201

int lo0
  ip addr 2.2.2.2 255.255.255.255

R3#
int s0/0
   encap frame-relay
   ip addr 123.123.123.3 255.255.255.0 
   frame-relay map ip 123.123.123.1 301 broadcast
   frame-relay map ip 123.123.123.2 301
int lo0
   ip addr 3.3.3.3 255.255.255.255

Check frame mapping. It should be active

R1#sh fram map
Serial0/0 (up): ip 123.123.123.2 dlci 102(0x66,0x1860), static,
              broadcast,
              CISCO, status defined, active
Serial0/0 (up): ip 123.123.123.3 dlci 103(0x67,0x1870), static,
              broadcast,
              CISCO, status defined, active

R2(config)#do sh fram map
Serial0/0 (up): ip 123.123.123.1 dlci 201(0xC9,0x3090), static,
              broadcast,
              CISCO, status defined, active
Serial0/0 (up): ip 123.123.123.3 dlci 201(0xC9,0x3090), static,
              CISCO, status defined, active

R3#sh fram map
Serial0/0 (up): ip 123.123.123.2 dlci 301(0x12D,0x48D0), static,
              CISCO, status defined, active
Serial0/0 (up): ip 123.123.123.1 dlci 301(0x12D,0x48D0), static,
              broadcast,
              CISCO, status defined, active

Make sure IP point to point already ok by test ping

R1#ping 123.123.123.2 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/23/52 ms

R1#ping 123.123.123.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/11/28 ms

R2(config)#do ping 123.123.123.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/19/52 ms

R2(config)#do ping 123.123.123.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 123.123.123.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/31/92 ms

Now, lets configure OSPF so the ip loopback can be ping

R1(config)#router ospf 1
R1(config-router)#network 1.1.1.1 0.0.0.0 area 0
R1(config-router)#network 123.123.123.1 0.0.0.0 area 0

R2(config)#router ospf 2
R2(config-router)#network 2.2.2.2 0.0.0.0 area 0
R2(config-router)#network 123.123.123.2 0.0.0.0 area 0

R3(config-if)#router ospf 3
R3(config-router)#network 3.3.3.3 0.0.0.0 area 0
R3(config-router)#network 123.123.123.3 0.0.0.0 area 0

Check OSPF neighbor

R1(config-router)#do sh ip ospf neighbor

R1(config-router)#

R2(config-if)#do sh ip ospf nei

R2(config-if)#




Hmm, actually default frame relay is Non Broadcast. It means no any OSPF adjacency to the neighbor by default. So we need to introduce all neighbors in OSPF

R3(config-if)#do sh ip ospf int s0/0
Serial0/0 is up, line protocol is up
  Internet Address 123.123.123.3/24, Area 0
  Process ID 3, Router ID 3.3.3.3, Network Type NON_BROADCAST, Cost: 64

 As we use hub, we need introduce all neighbors in hub only. In this example R1 is hub and R2 and R3 is spoke.

R1(config-if)#router ospf 1
R1(config-router)#neighbor 123.123.123.2
R1(config-router)#nei 123.123.123.3

Let's check the OSPF neighbor and routing table in R1, R2, and R3.

R1(config-router)#do sh ip ospf nei
Neighbor ID     Pri   State                        Dead Time   Address             Interface
2.2.2.2            1      FULL/DROTHER    00:01:46      123.123.123.2   Serial0/0
3.3.3.3            1      FULL/DR                 00:01:35      123.123.123.3   Serial0/0

R2(config-if)#do sh ip ospf nei
Neighbor ID     Pri   State                         Dead Time   Address             Interface
1.1.1.1             1     FULL/BDR               00:01:41      123.123.123.1   Serial0/0

R3(config-if)#do sh ip ospf nei
Neighbor ID     Pri   State                         Dead Time   Address             Interface
1.1.1.1             1     FULL/BDR               00:01:36      123.123.123.1   Serial0/0

R1(config-router)#do sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/65] via 123.123.123.3, 00:05:27, Serial0/0
     123.0.0.0/24 is subnetted, 1 subnets
C       123.123.123.0 is directly connected, Serial0/0

R2(config-if)#do sh ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     123.0.0.0/24 is subnetted, 1 subnets
C       123.123.123.0 is directly connected, Serial0/0

R3(config-if)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/65] via 123.123.123.1, 00:05:41, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     123.0.0.0/24 is subnetted, 1 subnets
C       123.123.123.0 is directly connected, Serial0/0

If we see in R2 and R3 the routing table is not complete. Than from neighbor information,  3.3.3.3 is the DR. So, this is the problem. R1 is hub and should be DR. Let's change R1 to be DR and R2/R3 can not be DR.

R1(config-router)#INT S0/0
R1(config-if)#ip ospf priority 255
R1(config-if)#shut
R1(config-if)#no shut

R2(config)#int s0/0
R2(config-if)#ip ospf prio 0
R2(config-if)#shut
R2(config-if)#no shu

R3(config-if)#int s0/0
R3(config-if)#ip ospf prio 0
R3(config-if)#shut
R3(config-if)#no shu

Just wait a moment... This is frame relay :)

*Mar  1 00:36:06.643: %OSPF-5-ADJCHG: Process 1, Nbr 0.0.0.0 on Serial0/0 from ATTEMPT to DOWN, Neighbor Down: Dead timer expired
*Mar  1 00:36:06.831: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial0/0 from LOADING to FULL, Loading Done
*Mar  1 00:36:06.955: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0 from LOADING to FULL, Loading Done

Oups, now the neighbor adjacency already up again. Let's check again the OSPF neighbor and routing table :)

R1(config-if)#do sh ip ospf nei
Neighbor ID     Pri   State                        Dead Time   Address            Interface
2.2.2.2              0    FULL/DROTHER    00:01:57     123.123.123.2   Serial0/0
3.3.3.3              0    FULL/DROTHER    00:01:50     123.123.123.3   Serial0/0

R2(config-if)#do sh ip ospf nei
Neighbor ID     Pri    State                 Dead Time   Address            Interface
1.1.1.1             255   FULL/DR         00:01:56     123.123.123.1   Serial0/0

R3(config-if)#do sh ip ospf nei
Neighbor ID     Pri     State                Dead Time   Address            Interface
1.1.1.1             255   FULL/DR         00:01:37     123.123.123.1   Serial0/0

R1(config-if)#do sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 123.123.123.2, 00:04:01, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/65] via 123.123.123.3, 00:04:01, Serial0/0
     123.0.0.0/24 is subnetted, 1 subnets
C       123.123.123.0 is directly connected, Serial0/0

R2(config-if)#do sh ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/65] via 123.123.123.1, 00:04:15, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/65] via 123.123.123.3, 00:04:15, Serial0/0
     123.0.0.0/24 is subnetted, 1 subnets
C       123.123.123.0 is directly connected, Serial0/0

R3(config-if)#do sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
O       1.1.1.1 [110/65] via 123.123.123.1, 00:04:32, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 123.123.123.2, 00:04:22, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     123.0.0.0/24 is subnetted, 1 subnets
C       123.123.123.0 is directly connected, Serial0/0

Now R2 should be able to ping to R3 and vice versa

R2(config-if)#do ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/32/108 ms

R3(config-if)#do ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/29/84 ms

No comments:

Post a Comment