My Countingdown

Tuesday, December 13, 2011

Lab 6. IPv6 tunneling




There are 5 tunneling from IPv6 to IPv4:
1. IPv6 tunnel IPv6IP, using IPv6 address, need source & destination
2. IPv6 tunnel GRE IP (by default), using IPv6 address, need source & destination
3. IPv6 tunnel 6to4, using IPv6 combine with IP source (IPv4), need source but no destination
4. IPv6 tunnel ISATAP, IPv6, need source but no destination
5. IPv6 tunnel Auto-Tunnel, no need IP, need source but no destination

Let’s make IPv6 Tunnel IPv6IP

R1#
interface Loopback0
 ipv6 address 1::1/128
!
interface Serial0/0
 ip address 12.12.12.1 255.255.255.0
!
router rip
 network 12.0.0.0

R2#
interface FastEthernet0/0
 ip address 23.23.23.2 255.255.255.0
!
interface Serial0/0
 ip address 12.12.12.2 255.255.255.0
!
router rip
 network 12.0.0.0
 network 23.0.0.0

R3#
interface Loopback0
 ipv6 address 3::3/128
!
interface FastEthernet0/0
 ip address 23.23.23.3 255.255.255.0
!
router rip
 network 23.0.0.0
  
Then make tunneling

R1#
interface Tunnel13
 ipv6 address 13::1/64
 tunnel source 12.12.12.1
 tunnel destination 23.23.23.3
 tunnel mode ipv6ip

R2#
interface Tunnel31
 no ip address
 ipv6 address 13::3/64
 tunnel source 23.23.23.3
 tunnel destination 12.12.12.1
 tunnel mode ipv6ip

Check ipv6 interface and type of tunneling

R1(config)#do sh ipv int bri
FastEthernet0/0            [administratively down/down]
Serial0/0                  [up/up]
FastEthernet0/1            [administratively down/down]
Serial0/1                  [administratively down/down]
Loopback0                  [up/up]
    FE80::C203:1AFF:FE6C:0
    1::1
Tunnel13                   [up/up]
    FE80::C0C:C01
    13::1

R3(config)#do sh ipv int bri
FastEthernet0/0            [up/up]
FastEthernet0/1            [administratively down/down]
Loopback0                  [up/up]
    FE80::C205:1AFF:FE6C:0
    3::3
Tunnel31                   [up/up]
    FE80::1717:1703
    13::3

R1(config)#do sh int tun13 | i Tunnel protocol
  Tunnel protocol/transport IPv6/IP

Make sure the ping ip p2p is ok

R1(config)#do ping 13::3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/27/60 ms

Check routing table

R1(config)#do sh ipv rou
IPv6 Routing Table - 4 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
LC  1::1/128 [0/0]
     via ::, Loopback0
C   13::/64 [0/0]
     via ::, Tunnel13
L   13::1/128 [0/0]
     via ::, Tunnel13
L   FF00::/8 [0/0]
     via ::, Null0

From routing table no ipv6 3::3 which is ip loopback. Hmmm, we need to add routing. Let’s use static route

R1(config)#ipv6 route 3::3/128 13::3

R3(config)#ipv6 route 1::1/128 13::1

Check routing table and make sure can ping to loopback another router

R1(config)#do sh ipv rou
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
LC  1::1/128 [0/0]
     via ::, Loopback0
S   3::3/128 [1/0]
     via 13::3
C   13::/64 [0/0]
     via ::, Tunnel13
L   13::1/128 [0/0]
     via ::, Tunnel13
L   FF00::/8 [0/0]
     via ::, Null0

R1(config)#do ping 3::3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/31/64 ms

No comments:

Post a Comment