My Countingdown

Tuesday, December 13, 2011

Lab 6. BGP Route Reflector






iBGP must full mesh. So if not full mesh there are 2 solution:
  1. Route Reflector. The router become BGP reflector. So all iBGP router have neighbor to route reflector for BGP peering. 
  2. BGP Confederation. There is Sub-AS in AS
 Let’s make R4 as route reflector. So R1 and R2 only connect to R4 for iBGP peering.

R1#
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.12.12.1 255.255.255.0
 no shu
!
interface Serial0/0
 ip address 14.14.14.1 255.255.255.0
 no shu
!
router rip
 ver 2
 net 1.0.0.0
 net 12.0.0.0
 net 14.0.0.0
 no auto
!
router bgp 124
 neighbor 4.4.4.4 remote-as 124
 neighbor 4.4.4.4 update-source loopback0
 neighbor 4.4.4.4 next-hop-self
 net 11.11.11.11 mask 255.255.255.255

R2#
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 12.12.12.2 255.255.255.0
 no shu
!
interface Serial0/0
 ip address 23.23.23.2 255.255.255.0
 no shu
!
router rip
 ver 2
 net 2.0.0.0
 net 12.0.0.0
 no auto
!
router bgp 124
 neighbor 4.4.4.4 remote-as 124
 neighbor 4.4.4.4 update-source loopback0
 neighbor 4.4.4.4 next-hop-self
 neighbor 23.23.23.3 remote-as 3
 redistribute rip
 redistribute connected


R3#
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
 ip address 23.23.23.3 255.255.255.0
 no shu
!
router bgp 3
 neighbor 23.23.23.2 remote-as 124
 net 3.3.3.3 mask 255.255.255.255

R4#                                                         --- - > Route reflector
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface Serial0/0
 ip address 14.14.14.4 255.255.255.0
 no shu
!
router rip
 ver 2
 net 4.0.0.0
 net 14.0.0.0
 no auto
!
router bgp 124
 neighbor 1.1.1.1 remote-as 124
 neighbor 1.1.1.1 update-source loopback0
 neighbor 1.1.1.1 next-hop-self
 neighbor 1.1.1.1 route-reflector-client
 neighbor 2.2.2.2 remote-as 124
 neighbor 2.2.2.2 update-source loopback0
 neighbor 2.2.2.2 next-hop-self
 neighbor 2.2.2.2 route-reflector-client

Let’s verify the bgp

R1(config-if)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     2.0.0.0/32 is subnetted, 1 subnets
R       2.2.2.2 [120/1] via 12.12.12.2, 00:00:26, FastEthernet0/0
     3.0.0.0/32 is subnetted, 1 subnets
B       3.3.3.3 [200/0] via 2.2.2.2, 00:05:33
     4.0.0.0/32 is subnetted, 1 subnets
R       4.4.4.4 [120/1] via 14.14.14.4, 00:00:23, Serial0/0
     23.0.0.0/24 is subnetted, 1 subnets
B       23.23.23.0 [200/0] via 2.2.2.2, 00:02:33
     11.0.0.0/32 is subnetted, 1 subnets
C       11.11.11.11 is directly connected, Loopback1
     12.0.0.0/24 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, FastEthernet0/0
     14.0.0.0/24 is subnetted, 1 subnets
C       14.14.14.0 is directly connected, Serial0/0

R1(config-if)#do sh ip bgp
BGP table version is 23, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r>i1.1.1.1/32       2.2.2.2                  1    100      0 ?
r>i2.2.2.2/32       2.2.2.2                  0    100      0 ?
*>i3.3.3.3/32       2.2.2.2                  0    100      0 3 i
r>i4.4.4.4/32       2.2.2.2                  2    100      0 ?
*> 11.11.11.11/32   0.0.0.0                  0         32768 i
r>i12.12.12.0/24    2.2.2.2                  0    100      0 ?
r>i14.14.14.0/24    2.2.2.2                  1    100      0 ?
*>i23.23.23.0/24    2.2.2.2                  0    100      0 ?

R1(config-if)#do sh ip bgp summ
BGP router identifier 1.1.1.1, local AS number 124
BGP table version is 23, main routing table version 23
8 network entries using 960 bytes of memory
8 path entries using 416 bytes of memory
6/5 BGP path/bestpath attribute entries using 744 bytes of memory
1 BGP rrinfo entries using 24 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 2200 total bytes of memory
BGP activity 11/3 prefixes, 11/3 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
4.4.4.4            4   124      19         11           23           0    0       00:07:13        7    --- > Peering only to RR

R2(config-router)#do sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 12.12.12.1, 00:00:25, FastEthernet0/0
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
B       3.3.3.3 [20/0] via 23.23.23.3, 00:05:55
     4.0.0.0/32 is subnetted, 1 subnets
R       4.4.4.4 [120/2] via 12.12.12.1, 00:00:25, FastEthernet0/0
     23.0.0.0/24 is subnetted, 1 subnets
C       23.23.23.0 is directly connected, Serial0/0
     11.0.0.0/32 is subnetted, 1 subnets
B       11.11.11.11 [200/0] via 1.1.1.1, 00:04:33
     12.0.0.0/24 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, FastEthernet0/0
     14.0.0.0/24 is subnetted, 1 subnets
R       14.14.14.0 [120/1] via 12.12.12.1, 00:00:01, FastEthernet0/0

R2(config-router)#do sh ip bgp
BGP table version is 15, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       12.12.12.1               1         32768 ?
*> 2.2.2.2/32       0.0.0.0                  0         32768 ?
*> 3.3.3.3/32       23.23.23.3               0             0 3 i
*> 4.4.4.4/32       12.12.12.1               2         32768 ?
*>i11.11.11.11/32   1.1.1.1                  0    100      0 i
*> 12.12.12.0/24    0.0.0.0                  0         32768 ?
*> 14.14.14.0/24    12.12.12.1               1         32768 ?
*> 23.23.23.0/24    0.0.0.0                  0         32768 ?

R2(config-router)#do sh ip bgp summ
BGP router identifier 2.2.2.2, local AS number 124
BGP table version is 15, main routing table version 15
8 network entries using 960 bytes of memory
8 path entries using 416 bytes of memory
6/5 BGP path/bestpath attribute entries using 744 bytes of memory
1 BGP rrinfo entries using 24 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 3 (at peak 4) using 96 bytes of memory
BGP using 2264 total bytes of memory
BGP activity 8/0 prefixes, 11/3 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
4.4.4.4            4   124      20           18         15         0    0 00:07:05             1   --- > Peering only to RR
23.23.23.3      4     3       11            18         15         0    0 00:06:13             1

R3(config-router)#do sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
B       1.1.1.1 [20/1] via 23.23.23.2, 00:02:12
     2.0.0.0/32 is subnetted, 1 subnets
B       2.2.2.2 [20/0] via 23.23.23.2, 00:03:22
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     4.0.0.0/32 is subnetted, 1 subnets
B       4.4.4.4 [20/2] via 23.23.23.2, 00:02:12
     23.0.0.0/24 is subnetted, 1 subnets
C       23.23.23.0 is directly connected, Serial0/0
     11.0.0.0/32 is subnetted, 1 subnets
B       11.11.11.11 [20/0] via 23.23.23.2, 00:05:00
     12.0.0.0/24 is subnetted, 1 subnets
B       12.12.12.0 [20/0] via 23.23.23.2, 00:03:24
     14.0.0.0/24 is subnetted, 1 subnets
B       14.14.14.0 [20/1] via 23.23.23.2, 00:02:14

R3(config-router)#do sh ip bgp
BGP table version is 16, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       23.23.23.2               1             0 124 ?
*> 2.2.2.2/32       23.23.23.2               0             0 124 ?
*> 3.3.3.3/32       0.0.0.0                  0         32768 i
*> 4.4.4.4/32       23.23.23.2               2             0 124 ?
*> 11.11.11.11/32   23.23.23.2                             0 124 i
*> 12.12.12.0/24    23.23.23.2               0             0 124 ?
*> 14.14.14.0/24    23.23.23.2               1             0 124 ?
r> 23.23.23.0/24    23.23.23.2               0             0 124 ?

R3(config-router)#do sh ip bgp summ
BGP router identifier 3.3.3.3, local AS number 3
BGP table version is 16, main routing table version 16
8 network entries using 960 bytes of memory
8 path entries using 416 bytes of memory
6/5 BGP path/bestpath attribute entries using 744 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 2176 total bytes of memory
BGP activity 8/0 prefixes, 11/3 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
23.23.23.2      4   124      18      11       16    0    0 00:06:36        7

R4(config-router)#do sh ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/1] via 14.14.14.1, 00:00:00, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
R       2.2.2.2 [120/2] via 14.14.14.1, 00:00:00, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
B       3.3.3.3 [200/0] via 2.2.2.2, 00:07:59
     4.0.0.0/32 is subnetted, 1 subnets
C       4.4.4.4 is directly connected, Loopback0
     23.0.0.0/24 is subnetted, 1 subnets
B       23.23.23.0 [200/0] via 2.2.2.2, 00:04:58
     11.0.0.0/32 is subnetted, 1 subnets
B       11.11.11.11 [200/0] via 1.1.1.1, 00:06:37
     12.0.0.0/24 is subnetted, 1 subnets
R       12.12.12.0 [120/1] via 14.14.14.1, 00:00:02, Serial0/0
     14.0.0.0/24 is subnetted, 1 subnets
C       14.14.14.0 is directly connected, Serial0/0

R4(config-router)#do sh ip bgp summ
BGP router identifier 4.4.4.4, local AS number 124
BGP table version is 23, main routing table version 23
8 network entries using 960 bytes of memory
8 path entries using 416 bytes of memory
6/5 BGP path/bestpath attribute entries using 744 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 2) using 32 bytes of memory
BGP using 2176 total bytes of memory
BGP activity 8/0 prefixes, 11/3 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1           4     124      13          21            23        0      0    00:09:36        1      --- > RR Client
2.2.2.2           4     124      19          21            23        0      0    00:08:59        7      --- > RR Client

R4(config-router)#do sh ip bgp
BGP table version is 23, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
r>i1.1.1.1/32       2.2.2.2                  1    100      0 ?
r>i2.2.2.2/32       2.2.2.2                  0    100      0 ?
*>i3.3.3.3/32       2.2.2.2                  0    100      0 3 i
r>i4.4.4.4/32       2.2.2.2                  2    100      0 ?
*>i11.11.11.11/32   1.1.1.1                  0    100      0 i
r>i12.12.12.0/24    2.2.2.2                  0    100      0 ?
r>i14.14.14.0/24    2.2.2.2                  1    100      0 ?
*>i23.23.23.0/24    2.2.2.2                  0    100      0 ?

Make sure can ping each other

R4(config-router)#do ping 3.3.3.3 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/70/112 ms

R3(config-router)#do ping 4.4.4.4 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/70/100 ms

No comments:

Post a Comment