My Countingdown

Friday, December 16, 2011

Lab 4. MPLS – PE – CE RIP Routing



Now we want to establish connection between PE and CE using RIP.
Let’s take example Mandiri. We have new customer Mandiri want to connect to our MPLS backbone using RIP to PE.

To do this lab, you need to do Lab-1 http://pursuingmydestiny.blogspot.com/2011/12/lab-1-mpls-backbone.html for establishing MPLS backbone and Lab-2 first http://pursuingmydestiny.blogspot.com/2011/12/lab-2-mpls-vpn.html for establishing MP-BGP only.
  
PE1#
ip vrf Mandiri
 rd 65000:3
 route-target export 65000:3
 route-target import 65000:3
!
interface Serial0/1
 description ###Link to Mandiri###
 ip vrf forwarding Mandiri
 ip address 192.168.1.1 255.255.255.252
!
router rip
 version 2
 !
 address-family ipv4 vrf Mandiri
  redistribute bgp 65000 metric transparent
  network 192.168.1.0
  no auto-summary
!
router bgp 65000
 address-family ipv4 vrf Mandiri
  redistribute rip

PE2#
ip vrf Mandiri
 rd 65000:3
 route-target export 65000:3
 route-target import 65000:3
!
interface Serial0/1
 description ###Link to Mandiri###
 ip vrf forwarding Mandiri
 ip address 192.168.1.5 255.255.255.252
!
router rip
 version 2
 !
 address-family ipv4 vrf Mandiri
  redistribute bgp 65000 metric transparent
  network 192.168.1.0
  no auto-summary
!
router bgp 65000
 address-family ipv4 vrf Mandiri
  redistribute rip

Mandiri1#
interface Loopback0
 ip address 200.200.200.1 255.255.255.255
!
interface Serial0/0
 ip address 192.168.1.2 255.255.255.252
!
router rip
 version 2
 network 0.0.0.0
 no auto-summary

Mandiri2#
interface Loopback0
 ip address 202.202.202.202 255.255.255.255
!
interface Serial0/0
 ip address 192.168.1.6 255.255.255.252
!
router rip
 version 2
 network 0.0.0.0
 no auto-summary

Let’s verify vpn Mandiri and check routing table

PE1#sh ip bgp vpnv4 vrf Mandiri
BGP table version is 29, local router ID is 10.10.10.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 65000:3 (default for vrf Mandiri)
*> 192.168.1.0/30   0.0.0.0                  0         32768 ?
*>i192.168.1.4/30   10.10.10.2               0    100      0 ?
*> 200.200.200.1/32 192.168.1.2              1         32768 ?
*>i202.202.202.202/32
                    10.10.10.2               1    100      0 ?

PE1#sh ip rou vrf Mandiri

Routing Table: Mandiri
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     200.200.200.0/32 is subnetted, 1 subnets
R       200.200.200.1 [120/1] via 192.168.1.2, 00:00:09, Serial0/1
     202.202.202.0/32 is subnetted, 1 subnets
B       202.202.202.202 [200/1] via 10.10.10.2, 00:09:33
     192.168.1.0/30 is subnetted, 2 subnets
C       192.168.1.0 is directly connected, Serial0/1
B       192.168.1.4 [200/0] via 10.10.10.2, 00:09:33

Mandiri1#sh ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     200.200.200.0/32 is subnetted, 1 subnets
C       200.200.200.1 is directly connected, Loopback0
     202.202.202.0/32 is subnetted, 1 subnets
R       202.202.202.202 [120/2] via 192.168.1.1, 00:00:10, Serial0/0
     192.168.1.0/30 is subnetted, 2 subnets
C       192.168.1.0 is directly connected, Serial0/0
R       192.168.1.4 [120/1] via 192.168.1.1, 00:00:10, Serial0/0

Test ping from Mandiri1 to Mandiri2 and do trace route

Mandiri1#ping 202.202.202.202
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 202.202.202.202, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 64/80/132 ms

Mandiri1#trac 202.202.202.202
Type escape sequence to abort.
Tracing the route to 202.202.202.202

  1 192.168.1.1 36 msec 28 msec 20 msec
  2 192.168.10.2 [MPLS: Labels 16/25 Exp 0] 76 msec 68 msec 56 msec
  3 192.168.1.5 [MPLS: Label 25 Exp 0] 88 msec 56 msec 60 msec
  4 192.168.1.6 100 msec *  124 msec 

1 comment:

  1. Hey My Friend i guess that are a mistake on a RIP Mandiri Advertise take a look below:

    ====
    PE2#
    !
    interface Serial0/1
    description ###Link to Mandiri###
    ip vrf forwarding Mandiri
    ip address 192.168.1.5 255.255.255.252
    !
    router rip
    version 2
    !
    address-family ipv4 vrf Mandiri
    network 192.168.1.0 --> change it to:
    network 192.168.1.4

    Because your Mandiri Interface belong to 192.168.1.4 prefix Am I right?

    See you later !

    ReplyDelete