My Countingdown

Monday, December 12, 2011

Lab 3. OSPF Standard Area


R1#
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 100.100.100.1 255.255.255.255
!
interface Loopback2
ip address 100.100.100.2 255.255.255.255
!
interface Loopback3
ip address 100.100.100.3 255.255.255.255
!
interface Loopback4
ip address 100.100.100.4 255.255.255.255
!
interface Loopback5
ip address 100.100.100.5 255.255.255.255
!
interface Loopback6
ip address 100.100.100.6 255.255.255.255
!
interface Loopback7
ip address 100.100.100.7 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
!
router eigrp 1
network 100.100.100.4 0.0.0.0
network 100.100.100.5 0.0.0.0
network 100.100.100.6 0.0.0.0
network 100.100.100.7 0.0.0.0
auto-summary
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
redistribute eigrp 1 subnets
network 1.1.1.1 0.0.0.0 area 0
network 12.12.12.1 0.0.0.0 area 0
network 100.100.100.1 0.0.0.0 area 100
network 100.100.100.2 0.0.0.0 area 100
network 100.100.100.3 0.0.0.0 area 100

R2#
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
!
interface Serial0/0
ip address 23.23.23.2 255.255.255.0
clock rate 2000000
!
router ospf 2
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 1
network 12.12.12.2 0.0.0.0 area 0
network 23.23.23.2 0.0.0.0 area 1

R3#
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
ip address 23.23.23.3 255.255.255.0
!
router ospf 3
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 1
network 23.23.23.3 0.0.0.0 area 1

Check routing table in R3

R3(config-router)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

        1.0.0.0/32 is subnetted, 1 subnets
O IA   1.1.1.1 [110/75] via 23.23.23.2, 00:04:57, Serial0/0
        2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/65] via 23.23.23.2, 00:04:57, Serial0/0
        100.0.0.0/32 is subnetted, 7 subnets
O E2 100.100.100.4 [110/20] via 23.23.23.2, 00:04:57, Serial0/0
O E2 100.100.100.5 [110/20] via 23.23.23.2, 00:04:57, Serial0/0
O E2 100.100.100.6 [110/20] via 23.23.23.2, 00:04:57, Serial0/0
O E2 100.100.100.7 [110/20] via 23.23.23.2, 00:04:57, Serial0/0
O IA 100.100.100.1 [110/75] via 23.23.23.2, 00:04:58, Serial0/0
O IA 100.100.100.2 [110/75] via 23.23.23.2, 00:04:58, Serial0/0
O IA 100.100.100.3 [110/75] via 23.23.23.2, 00:04:58, Serial0/0
        3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
        23.0.0.0/24 is subnetted, 1 subnets
C       23.23.23.0 is directly connected, Serial0/0
        12.0.0.0/24 is subnetted, 1 subnets
O IA 12.12.12.0 [110/74] via 23.23.23.2, 00:05:03, Serial0/0

Now check OSPF database in R3. We can LSA that advertise in R3

R3(config-router)#do sh ip ospf database

            OSPF Router with ID (3.3.3.3) (Process ID 3)

                         Router Link States (Area 1)               -----------------> LSA Type 1

Link ID            ADV Router      Age         Seq#             Checksum Link count
2.2.2.2             2.2.2.2               352         0x80000004 0x009846 3
3.3.3.3             3.3.3.3               351         0x80000002 0x00BB1D 3

                        Summary Net Link States (Area 1)      -----------------> LSA Type 3

Link ID             ADV Router      Age         Seq#            Checksum
1.1.1.1              2.2.2.2             527         0x80000001 0x008D98
12.12.12.0        2.2.2.2             527         0x80000001 0x00FF07
100.100.100.1   2.2.2.2             527         0x80000001 0x009368
100.100.100.2   2.2.2.2             527         0x80000001 0x008971
100.100.100.3   2.2.2.2             527         0x80000001 0x007F7A

                          Summary ASB Link States (Area 1)     -----------------> LSA Type 4

Link ID             ADV Router      Age         Seq#            Checksum
1.1.1.1              2.2.2.2              527         0x80000001 0x0075B0

                         Type-5 AS External Link States            -----------------> LSA Type 5

Link ID              ADV Router      Age         Seq#            Checksum Tag
100.100.100.4   1.1.1.1              720         0x80000001 0x0083E7 0
100.100.100.5   1.1.1.1              708         0x80000001 0x0079F0 0
100.100.100.6   1.1.1.1              696         0x80000001 0x006FF9 0
100.100.100.7   1.1.1.1              678         0x80000001 0x006503 0

No comments:

Post a Comment