My Countingdown

Thursday, December 8, 2011

Lab 5. RIP – Filtering – Standard ACL


R1#
interface Loopback1
ip address 10.0.0.1 255.255.255.255
!
interface Loopback2
ip address 10.0.0.2 255.255.255.255
!
interface Loopback3
ip address 10.0.0.3 255.255.255.255
!
interface Loopback4
ip address 10.0.0.4 255.255.255.255
!
interface Loopback5
ip address 10.0.0.5 255.255.255.255
!
interface Loopback6
ip address 10.0.0.6 255.255.255.255
!
router rip
version 2
network 10.0.0.0
network 12.0.0.0
no auto-summary

R2#
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.2 255.255.255.0
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
!
router rip
version 2
network 2.0.0.0
network 12.0.0.0
network 23.0.0.0
no auto-summary

R3#
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
!
router rip
version 2
network 3.0.0.0
network 23.0.0.0
no auto-summary

Let's check the routing table

R2(config-router)#do sh ip rou rip
  3.0.0.0/32 is subnetted, 1 subnets
R    3.3.3.3 [120/1] via 23.23.23.3, 00:00:05, FastEthernet0/0
  10.0.0.0/32 is subnetted, 6 subnets
R    10.0.0.2 [120/1] via 12.12.12.1, 00:00:01, Serial0/0
R    10.0.0.3 [120/1] via 12.12.12.1, 00:00:01, Serial0/0
R    10.0.0.1 [120/1] via 12.12.12.1, 00:00:01, Serial0/0
R    10.0.0.6 [120/1] via 12.12.12.1, 00:00:01, Serial0/0
R    10.0.0.4 [120/1] via 12.12.12.1, 00:00:01, Serial0/0
R    10.0.0.5 [120/1] via 12.12.12.1, 00:00:01, Serial0/0

R3#sh ip rou rip
  2.0.0.0/32 is subnetted, 1 subnets
R    2.2.2.2 [120/1] via 23.23.23.2, 00:00:07, FastEthernet0/0
  10.0.0.0/32 is subnetted, 6 subnets
R    10.0.0.2 [120/2] via 23.23.23.2, 00:00:07, FastEthernet0/0
R    10.0.0.3 [120/2] via 23.23.23.2, 00:00:07, FastEthernet0/0
R    10.0.0.1 [120/2] via 23.23.23.2, 00:00:07, FastEthernet0/0
R    10.0.0.6 [120/2] via 23.23.23.2, 00:00:07, FastEthernet0/0
R    10.0.0.4 [120/2] via 23.23.23.2, 00:00:07, FastEthernet0/0
R    10.0.0.5 [120/2] via 23.23.23.2, 00:00:07, FastEthernet0/0
  12.0.0.0/24 is subnetted, 1 subnets
R    12.12.12.0 [120/1] via 23.23.23.2, 00:00:07, FastEthernet0/0

Then we will do filtering in router R2 that only even IP loopback advertized by R1.

R2(config-router)#distribute 1 in s0/0
R2(config-router)#ex
R2(config)#access 1 permit 0.0.0.0 255.255.255.254

Let's check the routing table again

R2(config)#do clear ip rout *
R2(config)#do sh ip rou rip
  3.0.0.0/32 is subnetted, 1 subnets
R    3.3.3.3 [120/1] via 23.23.23.3, 00:00:04, FastEthernet0/0
  10.0.0.0/32 is subnetted, 3 subnets
R    10.0.0.2 [120/1] via 12.12.12.1, 00:00:02, Serial0/0
R    10.0.0.6 [120/1] via 12.12.12.1, 00:00:02, Serial0/0
R    10.0.0.4 [120/1] via 12.12.12.1, 00:00:02, Serial0/0

R3#clear ip rout *
R3#sh ip rou rip
  2.0.0.0/32 is subnetted, 1 subnets
R    2.2.2.2 [120/1] via 23.23.23.2, 00:00:00, FastEthernet0/0
  10.0.0.0/32 is subnetted, 3 subnets
R    10.0.0.2 [120/2] via 23.23.23.2, 00:00:00, FastEthernet0/0
R    10.0.0.6 [120/2] via 23.23.23.2, 00:00:00, FastEthernet0/0
R    10.0.0.4 [120/2] via 23.23.23.2, 00:00:00, FastEthernet0/0
  12.0.0.0/24 is subnetted, 1 subnets
R    12.12.12.0 [120/1] via 23.23.23.2, 00:00:00, FastEthernet0/0

Now, we only want odd IP loopback in R2.

R2(config)#no access 1 permit 0.0.0.0 255.255.255.254
R2(config)#access 1 permit 0.0.0.1 255.255.255.254

Let's check again the routing table

R2(config)#do clear ip rou *
R2(config)#do sh ip rou rip
  3.0.0.0/32 is subnetted, 1 subnets
R    3.3.3.3 [120/1] via 23.23.23.3, 00:00:04, FastEthernet0/0
  10.0.0.0/32 is subnetted, 3 subnets
R    10.0.0.3 [120/1] via 12.12.12.1, 00:00:04, Serial0/0
R    10.0.0.1 [120/1] via 12.12.12.1, 00:00:04, Serial0/0
R    10.0.0.5 [120/1] via 12.12.12.1, 00:00:04, Serial0/0

R3#clear ip rout *
R3#sh ip rou rip
  2.0.0.0/32 is subnetted, 1 subnets
R    2.2.2.2 [120/1] via 23.23.23.2, 00:00:03, FastEthernet0/0
  10.0.0.0/32 is subnetted, 3 subnets
R    10.0.0.3 [120/2] via 23.23.23.2, 00:00:03, FastEthernet0/0
R    10.0.0.1 [120/2] via 23.23.23.2, 00:00:03, FastEthernet0/0
R    10.0.0.5 [120/2] via 23.23.23.2, 00:00:03, FastEthernet0/0
  12.0.0.0/24 is subnetted, 1 subnets
R    12.12.12.0 [120/1] via 23.23.23.2, 00:00:03, FastEthernet0/0

No comments:

Post a Comment