My Countingdown

Thursday, December 8, 2011

Lab 7. RIP Filtering – Offset List


R1#
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
ip address 12.12.12.1 255.255.255.0
!
router rip
version 2
network 1.0.0.0
network 12.0.0.0
no auto-summary

R2#
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.2 255.255.255.0
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
!
router rip
version 2
network 2.0.0.0
network 12.0.0.0
network 23.0.0.0
no auto-summary
!

R3#
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
!
router rip
version 2
network 3.0.0.0
network 23.0.0.0
no auto-summary

Besides filtering using administrative distance, we can use using offset list. Offset list can be used only in RIP and EIGRP.

  • In RIP, offset list will add existing hop count
  • In EIGRP, offset list will add existing delay
  • To influence all the network use command 'offset-list 0'

R1(config-router)#do sh ip rout 3.3.3.3
Routing entry for 3.3.3.3/32
Known via "rip", distance 120, metric 2
Redistributing via rip
Last update from 12.12.12.2 on Serial0/0, 00:00:22 ago
Routing Descriptor Blocks:
* 12.12.12.2, from 12.12.12.2, 00:00:22 ago, via Serial0/0
Route metric is 2, traffic share count is 1

Now setting offset in R2 to add existing hopcount

R2(config)#router rip
R2(config-router)#offse
R2(config-router)#offset-list 1 out 13 s0/0
R2(config-router)#exi
R2(config)#access 1 permit host 3.3.3.3

R1(config-router)#do sh ip rout 3.3.3.3
Routing entry for 3.3.3.3/32
Known via "rip", distance 120, metric 15
Redistributing via rip
Last update from 12.12.12.2 on Serial0/0, 00:00:11 ago
Routing Descriptor Blocks:
* 12.12.12.2, from 12.12.12.2, 00:00:11 ago, via Serial0/0
Route metric is 15, traffic share count is 1

If we want 3.3.3.3 inaccessible from R1, so we can do by command ‘offset-list 1 out 14 s0/0’ in R2 so the metric will be 16. RIP allowed only 15 hop count.

R2(config)#router rip
R2(config-router)#offset-list 1 out 14 s0/0

R1(config-router)#do sh ip rout 3.3.3.3
% Network not in table

No comments:

Post a Comment