Let's make ip p2p and IGP as follow:
R1#
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
ip ospf 1 area 0
no shut
R2#
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
ip ospf 1 area 0
no shut
Let’s create NTP server in R1. Then R1 & R2 have ntp authentication
R1#
R1#clock set 11:41:00 15 december 2011 ---- > in exec mode
R1(config)#clock timezone jakarta 7
R1(config)#ntp master 2
R1(config)#ntp authentication-key 1 md5 cisco
R2#
R2(config-if)#ntp server 1.1.1.1
R2(config)#ntp authentication-key 1 md5 cisco
R2(config)#ntp authenticate
R2(config)#ntp trusted-key 1
R2(config)#ntp server 1.1.1.1 key 1
Verify ntp & clock
R1#show clock
11:44:37.511 jakarta Thu Dec 15 2011
R1#show ntp status
Clock is synchronized, stratum 2, reference is 127.127.7.1
nominal freq is 250.0000 Hz, actual freq is 250.0000 Hz, precision is 2**18
reference time is D293F98E.65638BB2 (11:43:58.396 jakarta Thu Dec 15 2011)
clock offset is 0.0000 msec, root delay is 0.00 msec
root dispersion is 0.02 msec, peer dispersion is 0.02 msec
R1#sh ntp associations
address ref clock st when poll reach delay offset disp
*~127.127.7.1 .LOCL. 1 45 64 377 0.0 0.00 0.0
* master (synced), # master (unsynced), + selected, - candidate, ~ configured
R2(config)#do sh clock
.04:44:47.834 UTC Thu Dec 15 2011
R2(config)#do sh ntp stat
Clock is unsynchronized, stratum 16, no reference clock
nominal freq is 250.0000 Hz, actual freq is 250.0000 Hz, precision is 2**18
reference time is C029479E.E7672A48 (00:19:42.903 UTC Fri Mar 1 2002)
clock offset is 308982290666.1083 msec, root delay is 91.71 msec
root dispersion is 19965208.94 msec, peer dispersion is 16000.00 msec
Just wait! Check again!
R2(config)#do sh ntp stat
Clock is synchronized, stratum 3, reference is 1.1.1.1
nominal freq is 250.0000 Hz, actual freq is 250.0000 Hz, precision is 2**18
reference time is D2945B98.1C940849 (11:42:16.111 UTC Thu Dec 15 2011)
clock offset is -13.7526 msec, root delay is 27.68 msec
root dispersion is 25.10 msec, peer dispersion is 11.31 msec
R2(config)#do sh ntp associ
address ref clock st when poll reach delay offset disp
~1.1.1.1 127.127.7.1 2 20 64 0 91.7 308982 16000.
* master (synced), # master (unsynced), + selected, - candidate, ~ configured
Oupsss… the clock is not the same!!! Make sure the time zone is the same!
R2(config)#clock timezone jakarta 7
Dec 15 04:46:03.776: %SYS-6-CLOCKUPDATE: System clock has been updated from 04:46:03 UTC Thu Dec 15 2011 to 11:46:03 jakarta Thu Dec 15 2011, configured from console by console.
R2(config)#do sh clock
11:46:09.589 jakarta Thu Dec 15 2011
No comments:
Post a Comment