My Countingdown

Thursday, December 8, 2011

Lab 3. RIP Summary Address


R1#
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback10
ip address 10.0.0.1 255.255.255.0
!
interface Loopback11
ip address 10.0.1.1 255.255.255.0
!
interface Loopback12
ip address 10.0.2.1 255.255.255.0
!
interface Loopback13
ip address 10.0.3.1 255.255.255.0
!
interface Loopback14
ip address 10.4.0.1 255.255.255.0
!
interface Loopback15
ip address 10.5.0.1 255.255.255.0
!
interface Loopback16
ip address 10.6.0.1 255.255.255.0
!
interface Loopback17
ip address 10.7.0.1 255.255.255.0
!
interface Loopback18
ip address 10.8.0.1 255.255.255.0
!
interface Loopback20
ip address 11.0.0.1 255.255.255.0
!
interface Loopback21
ip address 11.0.1.1 255.255.255.0
!
interface Loopback22
ip address 11.0.2.1 255.255.255.0
!
interface Loopback23
ip address 11.0.3.1 255.255.255.0
!
interface Loopback24
ip address 11.0.4.1 255.255.255.0
!
interface Loopback31
ip address 12.0.0.1 255.255.255.255
!
interface Loopback32
ip address 12.0.0.2 255.255.255.255
!
interface Loopback33
ip address 12.0.0.3 255.255.255.255
!
interface Loopback34
ip address 12.0.0.4 255.255.255.255
!
interface Serial0/0
ip address 12.12.12.1 255.255.255.0
clock rate 2000000
!
router rip
version 2
network 1.0.0.0
network 10.0.0.0
network 11.0.0.0
network 12.0.0.0
no auto-summary

R2#
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
clock rate 2000000
!
router rip
version 2
network 2.0.0.0
network 12.0.0.0
network 23.0.0.0
no auto-summary

R3#
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
!
router rip
version 2
network 3.0.0.0
network 23.0.0.0
no auto-summary

Let's check the routing table

R2#sh ip rout rip
   1.0.0.0/32 is subnetted, 1 subnets
R    1.1.1.1 [120/1] via 12.12.12.1, 00:00:09, Serial0/0
   3.0.0.0/32 is subnetted, 1 subnets
R    3.3.3.3 [120/1] via 23.23.23.3, 00:00:06, FastEthernet0/0
   10.0.0.0/24 is subnetted, 9 subnets
R    10.8.0.0 [120/1] via 12.12.12.1, 00:00:09, Serial0/0
R    10.0.2.0 [120/1] via 12.12.12.1, 00:00:09, Serial0/0
R    10.0.3.0 [120/1] via 12.12.12.1, 00:00:09, Serial0/0
R    10.0.0.0 [120/1] via 12.12.12.1, 00:00:09, Serial0/0
R    10.0.1.0 [120/1] via 12.12.12.1, 00:00:09, Serial0/0
R    10.6.0.0 [120/1] via 12.12.12.1, 00:00:09, Serial0/0
R    10.7.0.0 [120/1] via 12.12.12.1, 00:00:09, Serial0/0
R    10.4.0.0 [120/1] via 12.12.12.1, 00:00:09, Serial0/0
R    10.5.0.0 [120/1] via 12.12.12.1, 00:00:09, Serial0/0
   11.0.0.0/24 is subnetted, 5 subnets
R    11.0.3.0 [120/1] via 12.12.12.1, 00:00:09, Serial0/0
R    11.0.2.0 [120/1] via 12.12.12.1, 00:00:09, Serial0/0
R    11.0.1.0 [120/1] via 12.12.12.1, 00:00:09, Serial0/0
R    11.0.0.0 [120/1] via 12.12.12.1, 00:00:11, Serial0/0
R    11.0.4.0 [120/1] via 12.12.12.1, 00:00:11, Serial0/0
   12.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
R    12.0.0.4/32 [120/1] via 12.12.12.1, 00:00:11, Serial0/0
R    12.0.0.1/32 [120/1] via 12.12.12.1, 00:00:11, Serial0/0
R    12.0.0.2/32 [120/1] via 12.12.12.1, 00:00:12, Serial0/0
R    12.0.0.3/32 [120/1] via 12.12.12.1, 00:00:12, Serial0/0

R3#sh ip rout rip
   1.0.0.0/32 is subnetted, 1 subnets
R    1.1.1.1 [120/2] via 23.23.23.2, 00:00:12, FastEthernet0/0
   2.0.0.0/32 is subnetted, 1 subnets
R    2.2.2.2 [120/1] via 23.23.23.2, 00:00:12, FastEthernet0/0
   10.0.0.0/24 is subnetted, 9 subnets
R    10.8.0.0 [120/2] via 23.23.23.2, 00:00:12, FastEthernet0/0
R    10.0.2.0 [120/2] via 23.23.23.2, 00:00:12, FastEthernet0/0
R    10.0.3.0 [120/2] via 23.23.23.2, 00:00:12, FastEthernet0/0
R    10.0.0.0 [120/2] via 23.23.23.2, 00:00:12, FastEthernet0/0
R    10.0.1.0 [120/2] via 23.23.23.2, 00:00:12, FastEthernet0/0
R    10.6.0.0 [120/2] via 23.23.23.2, 00:00:12, FastEthernet0/0
R    10.7.0.0 [120/2] via 23.23.23.2, 00:00:12, FastEthernet0/0
R    10.4.0.0 [120/2] via 23.23.23.2, 00:00:12, FastEthernet0/0
R    10.5.0.0 [120/2] via 23.23.23.2, 00:00:12, FastEthernet0/0
   11.0.0.0/24 is subnetted, 5 subnets
R    11.0.3.0 [120/2] via 23.23.23.2, 00:00:12, FastEthernet0/0
R    11.0.2.0 [120/2] via 23.23.23.2, 00:00:12, FastEthernet0/0
R    11.0.1.0 [120/2] via 23.23.23.2, 00:00:14, FastEthernet0/0
R    11.0.0.0 [120/2] via 23.23.23.2, 00:00:14, FastEthernet0/0
R    11.0.4.0 [120/2] via 23.23.23.2, 00:00:14, FastEthernet0/0
   12.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
R    12.0.0.4/32 [120/2] via 23.23.23.2, 00:00:14, FastEthernet0/0
R    12.12.12.0/24 [120/1] via 23.23.23.2, 00:00:14, FastEthernet0/0
R    12.0.0.1/32 [120/2] via 23.23.23.2, 00:00:16, FastEthernet0/0
R    12.0.0.2/32 [120/2] via 23.23.23.2, 00:00:16, FastEthernet0/0
R    12.0.0.3/32 [120/2] via 23.23.23.2, 00:00:16, FastEthernet0/0

Now, let's summary address RIP in R1 so other router just get the summary 

R1(config-if)#int s0/0
R1(config-if)#ip summ rip 10.0.0.0 255.0.0.0
R1(config-if)#ip summ rip 11.0.0.0 255.0.0.0

R2#clear ip route *
R2#sh ip rout rip
   1.0.0.0/32 is subnetted, 1 subnets
R    1.1.1.1 [120/1] via 12.12.12.1, 00:00:02, Serial0/0
   3.0.0.0/32 is subnetted, 1 subnets
R    3.3.3.3 [120/1] via 23.23.23.3, 00:00:02, FastEthernet0/0
R    10.0.0.0/8 [120/1] via 12.12.12.1, 00:00:02, Serial0/0
R    11.0.0.0/8 [120/1] via 12.12.12.1, 00:00:02, Serial0/0
   12.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
R    12.0.0.4/32 [120/1] via 12.12.12.1, 00:00:02, Serial0/0
R    12.0.0.1/32 [120/1] via 12.12.12.1, 00:00:02, Serial0/0
R    12.0.0.2/32 [120/1] via 12.12.12.1, 00:00:02, Serial0/0
R    12.0.0.3/32 [120/1] via 12.12.12.1, 00:00:02, Serial0/0

R3#clear ip rou *
R3#sh ip rout rip
  1.0.0.0/32 is subnetted, 1 subnets
R    1.1.1.1 [120/2] via 23.23.23.2, 00:00:04, FastEthernet0/0
  2.0.0.0/32 is subnetted, 1 subnets
R    2.2.2.2 [120/1] via 23.23.23.2, 00:00:04, FastEthernet0/0
R    10.0.0.0/8 [120/2] via 23.23.23.2, 00:00:04, FastEthernet0/0
R    11.0.0.0/8 [120/2] via 23.23.23.2, 00:00:04, FastEthernet0/0
  12.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
R    12.0.0.4/32 [120/2] via 23.23.23.2, 00:00:04, FastEthernet0/0
R    12.12.12.0/24 [120/1] via 23.23.23.2, 00:00:04, FastEthernet0/0
R    12.0.0.1/32 [120/2] via 23.23.23.2, 00:00:04, FastEthernet0/0
R    12.0.0.2/32 [120/2] via 23.23.23.2, 00:00:04, FastEthernet0/0
R    12.0.0.3/32 [120/2] via 23.23.23.2, 00:00:04, FastEthernet0/0

No comments:

Post a Comment