My Countingdown

Tuesday, December 13, 2011

Lab 4. EIGRP - Redistribute RIP




R1#
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 100.100.100.1 255.255.255.255
!
interface Loopback2
ip address 200.200.200.1 255.255.255.255
!
interface Loopback3
ip address 30.30.30.1 255.255.255.255
!
interface Serial0/0
ip address 12.12.12.1 255.255.255.0
!
router eigrp 10
network 1.1.1.1 0.0.0.0
network 12.12.12.1 0.0.0.0
no auto-summary
!
router ospf 1
log-adjacency-changes
network 30.30.30.1 0.0.0.0 area 0
!
router rip
version 2
network 200.200.200.0

R2#
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.2 255.255.255.0
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
!
router eigrp 10
network 2.2.2.2 0.0.0.0
network 12.12.12.2 0.0.0.0
network 23.23.23.2 0.0.0.0
no auto-summary

R3#
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 10.0.0.1 255.255.255.255
!
interface Loopback2
ip address 10.0.0.2 255.255.255.255
!
interface Loopback3
ip address 10.0.0.3 255.255.255.255
!
interface Loopback4
ip address 10.0.0.4 255.255.255.255
!
interface Loopback5
ip address 10.0.0.5 255.255.255.255
!
interface Loopback6
ip address 10.0.0.6 255.255.255.255
!
interface Loopback7
ip address 10.0.0.7 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
!
router eigrp 10
network 3.3.3.3 0.0.0.0
network 10.0.0.1 0.0.0.0
network 10.0.0.2 0.0.0.0
network 10.0.0.3 0.0.0.0
network 10.0.0.4 0.0.0.0
network 10.0.0.5 0.0.0.0
network 10.0.0.6 0.0.0.0
network 10.0.0.7 0.0.0.0
network 23.23.23.3 0.0.0.0
no auto-summary

We want IP 200.200.200.1 in R1 that already advertize using RIP can be accessed using EIGRP

R1(config)#router eigrp 10
R1(config-router)#redis rip metric 1 1 1 1 1
R1(config-router)#
R1(config-router)#
R1(config-router)#do sh ip pro
Routing Protocol is "eigrp 10"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Serial0/0 filtered by 1, default is 1
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 10, rip
EIGRP NSF-aware route hold timer is 240s
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
1.1.1.1/32
12.12.12.1/32

R3(config-if)#do sh ip route eigrp
  200.200.200.0/32 is subnetted, 1 subnets
D EX 200.200.200.1 [170/2560537856] via 23.23.23.2, 00:01:09, FastEthernet0/0
  1.0.0.0/32 is subnetted, 1 subnets
D      1.1.1.1 [90/2323456] via 23.23.23.2, 00:31:34, FastEthernet0/0
  2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/409600] via 23.23.23.2, 00:31:34, FastEthernet0/0
  100.0.0.0/32 is subnetted, 1 subnets
D EX 100.100.100.1 [170/2195456] via 23.23.23.2, 00:05:09, FastEthernet0/0
  12.0.0.0/24 is subnetted, 1 subnets
D       12.12.12.0 [90/2195456] via 23.23.23.2, 00:31:34, FastEthernet0/0

R3(config-if)#do ping 200.200.200.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.200.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/51/76 ms

No comments:

Post a Comment