My Countingdown

Friday, December 16, 2011

Lab 5. MPLS – PE – CE EIGRP Routing




Now we want to establish connection between PE and CE using EIGRP.
Let’s take example Niaga. We have new customer Niaga want to connect to our MPLS backbone using EIGRP to PE.

To do this lab, you need to do Lab-1 http://pursuingmydestiny.blogspot.com/2011/12/lab-1-mpls-backbone.html for establishing MPLS backbone and Lab-2 first http://pursuingmydestiny.blogspot.com/2011/12/lab-2-mpls-vpn.html for establishing MP-BGP only.

PE1#
ip vrf Niaga
 rd 65000:4
 route-target export 65000:4
 route-target import 65000:4
!
interface Serial0/2
 ip vrf forwarding Niaga
 ip address 192.168.2.1 255.255.255.252
!
router eigrp 65000
 address-family ipv4 vrf Niaga
  redistribute bgp 65000 metric 1 1 1 1 1
  network 192.168.2.0
  autonomous-system 100
!
router bgp 65000
 address-family ipv4 vrf Niaga
  redistribute eigrp 100

PE2#
ip vrf Niaga
 rd 65000:4
 route-target export 65000:4
 route-target import 65000:4
!
interface Serial0/2
 ip vrf forwarding Niaga
 ip address 192.168.2.5 255.255.255.252
!
router eigrp 65000
 address-family ipv4 vrf Niaga
  redistribute bgp 65000 metric 1 1 1 1 1
  network 192.168.2.0
  autonomous-system 100
!
router bgp 65000
 address-family ipv4 vrf Niaga
  redistribute eigrp 100

Niaga1#
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface Serial0/0
 ip address 192.168.2.2 255.255.255.252
!
router eigrp 100
 network 0.0.0.0
 no auto-summary

Niaga2#
!
interface Loopback0
 ip address 55.55.55.55 255.255.255.255
!
interface Serial0/0
 ip address 192.168.2.6 255.255.255.252
!
router eigrp 100
 network 0.0.0.0
 no auto-summary

Let’s check vpn vrf Niaga

PE1#sh ip bgp vpnv4 vrf Niaga
BGP table version is 41, local router ID is 10.10.10.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 65000:4 (default for vrf Niaga)
*> 5.5.5.5/32       192.168.2.2        2297856         32768 ?
*>i55.55.55.55/32   10.10.10.2         2297856    100      0 ?
*> 192.168.2.0/30   0.0.0.0                  0         32768 ?
*>i192.168.2.4/30   10.10.10.2               0    100      0 ?

Let’s check routing table vrf Niaga

PE1#sh ip rou vrf Niaga

Routing Table: Niaga
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     55.0.0.0/32 is subnetted, 1 subnets
B       55.55.55.55 [200/2297856] via 10.10.10.2, 00:06:23
     5.0.0.0/32 is subnetted, 1 subnets
D       5.5.5.5 [90/2297856] via 192.168.2.2, 00:06:31, Serial0/2
     192.168.2.0/30 is subnetted, 2 subnets
C       192.168.2.0 is directly connected, Serial0/2
B       192.168.2.4 [200/0] via 10.10.10.2, 00:06:23

Let’s check routing table in customer site

Niaga1#sh ip rou
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     55.0.0.0/32 is subnetted, 1 subnets
D       55.55.55.55 [90/2809856] via 192.168.2.1, 00:07:09, Serial0/0
     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback0
     192.168.2.0/30 is subnetted, 2 subnets
C       192.168.2.0 is directly connected, Serial0/0
D       192.168.2.4 [90/2681856] via 192.168.2.1, 00:07:09, Serial0/0

Let’s test ping and trace route from Niaga1 to Niaga2

Niaga1#ping 55.55.55.55
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 55.55.55.55, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 60/96/144 ms

Niaga1#trac 55.55.55.55
Type escape sequence to abort.
Tracing the route to 55.55.55.55
  1 192.168.2.1 36 msec 60 msec 8 msec
  2 192.168.10.2 [MPLS: Labels 16/27 Exp 0] 72 msec 36 msec 60 msec
  3 192.168.2.5 [MPLS: Label 27 Exp 0] 104 msec 60 msec 104 msec
  4 192.168.2.6 120 msec *  84 msec

No comments:

Post a Comment