My Countingdown

Thursday, December 8, 2011

Lab 2. RIP Split Horizon


Split horizon prevent the route sent from other router to router sender.

R1#
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
!
interface Serial0/0.123 multipoint
ip address 123.123.123.1 255.255.255.0
snmp trap link-status
frame-relay map ip 123.123.123.3 103 broadcast
frame-relay map ip 123.123.123.2 102 broadcast
!
router rip
version 2
network 0.0.0.0
no auto-summary

R2#
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Serial0/0
ip address 123.123.123.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 123.123.123.1 201 broadcast
frame-relay map ip 123.123.123.3 201
!
router rip
version 2
network 0.0.0.0
no auto-summary

R3#
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
ip address 123.123.123.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 123.123.123.1 301 broadcast
frame-relay map ip 123.123.123.2 301
!
router rip
version 2
network 0.0.0.0
no auto-summary

Check frame relay mapping

R1(config-subif)#do sh fram map
Serial0/0.123 (up): ip 123.123.123.2 dlci 102(0x66,0x1860), static,
broadcast,
CISCO, status defined, active
Serial0/0.123 (up): ip 123.123.123.3 dlci 103(0x67,0x1870), static,
broadcast,
CISCO, status defined, active

R2#sh fram map
Serial0/0 (up): ip 123.123.123.1 dlci 201(0xC9,0x3090), static,
broadcast,
CISCO, status defined, active
Serial0/0 (up): ip 123.123.123.3 dlci 201(0xC9,0x3090), static,
CISCO, status defined, active

R3#sh fram map
Serial0/0 (up): ip 123.123.123.1 dlci 301(0x12D,0x48D0), static,
broadcast,
CISCO, status defined, active
Serial0/0 (up): ip 123.123.123.2 dlci 301(0x12D,0x48D0), static,
CISCO, status defined, active

Check the routing table and the ping should ok from all router

R1(config-subif)#do sh ip rout rip
   2.0.0.0/32 is subnetted, 1 subnets
R   2.2.2.2 [120/1] via 123.123.123.2, 00:00:08, Serial0/0.123
   3.0.0.0/32 is subnetted, 1 subnets
R    3.3.3.3 [120/1] via 123.123.123.3, 00:00:15, Serial0/0.123

R1(config-subif)#do ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/17/40 ms

R1(config-subif)#do ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/30/64 ms

R2#sh ip route rip
   1.0.0.0/32 is subnetted, 1 subnets
R    1.1.1.1 [120/1] via 123.123.123.1, 00:00:21, Serial0/0

R2#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/19/60 ms

R2#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

R3#sh ip rout rip
   1.0.0.0/32 is subnetted, 1 subnets
R   1.1.1.1 [120/1] via 123.123.123.1, 00:00:22, Serial0/0

R3#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/23/44 ms

R3#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

R3#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

We can see R1 have all routing table R2 and R3. R2 have only get RIP from R1 and R3 also have only RIP from R1. So R2 and R3 can not talk each other. It's because split horizon. Check split horizon

R1(config-subif)#do sh ip int s0/0 | i Split
R1(config-subif)#do sh ip int s0/0.123 | i Split
Split horizon is enabled

R2#sh ip int s0/0 | i Split
Split horizon is disabled

R3#sh ip int s0/0 | i Split
Split horizon is disabled

Ok, now let's disable split horizon in R1.

R1(config-subif)#int s0/0.123
R1(config-subif)#no ip split-horizon
R1(config-subif)#do clear ip route *

Let's check routing table in R2 and R3

R2#sh ip route rip
   1.0.0.0/32 is subnetted, 1 subnets
R    1.1.1.1 [120/1] via 123.123.123.1, 00:00:25, Serial0/0
   3.0.0.0/32 is subnetted, 1 subnets
R    3.3.3.3 [120/2] via 123.123.123.3, 00:00:25, Serial0/0

R3#sh ip rout rip
    1.0.0.0/32 is subnetted, 1 subnets
R    1.1.1.1 [120/1] via 123.123.123.1, 00:00:06, Serial0/0
    2.0.0.0/32 is subnetted, 1 subnets
R     2.2.2.2 [120/2] via 123.123.123.2, 00:00:06, Serial0/0

R3#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/46/152 ms

R3#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/43/144 ms

No comments:

Post a Comment