My Countingdown

Tuesday, December 13, 2011

Lab 8. EIGRP - Unicast Update




R1#
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 100.100.100.1 255.255.255.255
!
interface Loopback2
ip address 200.200.200.1 255.255.255.255
!
interface Loopback3
ip address 30.30.30.1 255.255.255.255
!
interface Serial0/0
ip address 12.12.12.1 255.255.255.0
!
router eigrp 10
network 1.1.1.1 0.0.0.0
network 12.12.12.1 0.0.0.0
no auto-summary
!
router ospf 1
log-adjacency-changes
network 30.30.30.1 0.0.0.0 area 0
!
router rip
version 2
network 200.200.200.0

R2#
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.2 255.255.255.0
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
!
router eigrp 10
network 2.2.2.2 0.0.0.0
network 12.12.12.2 0.0.0.0
network 23.23.23.2 0.0.0.0
no auto-summary

R3#
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 10.0.0.1 255.255.255.255
!
interface Loopback2
ip address 10.0.0.2 255.255.255.255
!
interface Loopback3
ip address 10.0.0.3 255.255.255.255
!
interface Loopback4
ip address 10.0.0.4 255.255.255.255
!
interface Loopback5
ip address 10.0.0.5 255.255.255.255
!
interface Loopback6
ip address 10.0.0.6 255.255.255.255
!
interface Loopback7
ip address 10.0.0.7 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
!
router eigrp 10
network 3.3.3.3 0.0.0.0
network 10.0.0.1 0.0.0.0
network 10.0.0.2 0.0.0.0
network 10.0.0.3 0.0.0.0
network 10.0.0.4 0.0.0.0
network 10.0.0.5 0.0.0.0
network 10.0.0.6 0.0.0.0
network 10.0.0.7 0.0.0.0
network 23.23.23.3 0.0.0.0
no auto-summary

By default EIGRP, update using multicast 224.0.0.10

R1(config-if)#do debu ip packet deta
IP packet debugging is on (detailed)
R1(config-if)#
*Mar 1 00:58:50.535: IP: s=1.1.1.1 (local), d=224.0.0.10 (Loopback0), len 60, sending broad/multicast, proto=88
*Mar 1 00:58:50.539: IP: s=1.1.1.1 (Loopback0), d=224.0.0.10, len 60, rcvd 2, proto=88
*Mar 1 00:58:51.203: IP: s=12.12.12.2 (Serial0/0), d=224.0.0.10, len 100, rcvd 2, proto=88

We can change the multicast into unicast using ‘neighbor command’.

R1(config-if)#router eigrp 10
R1(config-router)#nei 12.12.12.2 s0/0

R2(config-if)#router eigrp 10
R2(config-router)#nei 12.12.12.1 s0/0

R1(config-router)#do debu ip packet deta
*Mar 1 01:01:14.051: IP: s=12.12.12.1 (local), d=12.12.12.2 (Serial0/0), len 100, sending, proto=88
*Mar 1 01:01:14.171: IP: tableid=0, s=12.12.12.2 (Serial0/0), d=12.12.12.1 (Serial0/0), routed via RIB
*Mar 1 01:01:14.171: IP: s=12.12.12.2 (Serial0/0), d=12.12.12.1 (Serial0/0), len 100, rcvd 3, proto=88

No comments:

Post a Comment