My Countingdown

Sunday, December 4, 2011

Lab1. Frame Relay Inverse ARP

As I promise, I will share detail lab what I did yesterday regarding Frame Relay stuff.
Frame relay is Network Broadcast Multi Access (NBMA). There are 2 type networks in frame-relay i.e. multipoint and point-to-point. The default is multipoint.
Using multipoint, it’s needed mapping layer 3 (IP) to layer 2 (DLCI). And to do mapping, there 2 ways:
1. Dynamic mapping using inverse-ARP
2. Static mapping using command ‘frame-relay map’


Then let’s have a look to our simple topology.




So R1 need to communicate to R2 via frame relay switching. DLCI for R1 is 102 and for R2 is 201.

R1(config)#interface Serial0/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no shutdown

R1(config)#interface Serial0/0
R1(config-if)#ip address 12.12.12.2 255.255.255.0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no shutdown

To do activation frame-relay, it can be done by using command ‘frame-relay switching’

FR(config)#frame-relay switching
FR(config)#interface Serial0/0
FR(config-if)#encapsulation frame-relay
FR(config-if)#frame-relay lmi-type cisco
FR(config-if)#frame-relay intf-type dce
FR(config-if)#frame-relay route 102 interface Serial0/1 201
FR(config-if)#no shutdown

FR(config-if)#interface Serial0/1
FR(config-if)#encapsulation frame-relay
FR(config-if)#frame-relay lmi-type cisco
FR(config-if)#frame-relay intf-type dce
FR(config-if)#frame-relay route 201 interface Serial0/0 102
FR(config-if)#no shutdown

In here, we already did the frame-relay configuration. Let’s check the status frame-relay in R1 & R2.

R1#show frame-relay map
Serial0/0 (up): ip 12.12.12.2 dlci 102(0x66,0x1860), dynamic,
broadcast,, status defined, active

R1#show frame-relay pvc
PVC Statistics for interface Serial0/0 (Frame Relay DTE)
Active Inactive Deleted Static
Local 1 0 0 0
Switched 0 0 0 0
Unused 0 0 0 0
DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0
input pkts 4 output pkts 3 in bytes 136
out bytes 102 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 3 out bcast bytes 102
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:47:03, last time pvc status changed 00:47:03

R2#show frame-relay map
Serial0/0 (up): ip 12.12.12.1 dlci 201(0xC9,0x3090), dynamic,
broadcast,, status defined, active

R2#show frame-relay pvc
PVC Statistics for interface Serial0/0 (Frame Relay DTE)
Active Inactive Deleted Static
Local 1 0 0 0
Switched 0 0 0 0
Unused 0 0 0 0
DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0
input pkts 4 output pkts 2 in bytes 136
out bytes 68 dropped pkts 0 in pkts dropped 0
out pkts dropped 0 out bytes dropped 0
in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
out BECN pkts 0 in DE pkts 0 out DE pkts 0
out bcast pkts 2 out bcast bytes 68
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:47:59, last time pvc status changed 00:47:59

Check the ping!

R1#ping 12.12.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/28/68 ms

R2#ping 12.12.12.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/26/60 ms

Check the mapping using ‘show frame-relay map’. There are 3 status of mapping:
1. Active : mapping is working fine, link ready to used
2. Deleted : there is problem in that router to frame relay switch
3. Inactive : there is problem in side of another router

No comments:

Post a Comment